New 21.5" iMac Speakers

Discussion in 'iMac' started by andrewoc, Oct 27, 2009.

  1. andrewoc macrumors newbie

    Joined:
    Sep 18, 2009
    #1
    Whenever I'mn watching a youtube video, or listening to something on iTunes, the audio is muffled. I tried reinstalling snow leopard, but no results. Help?
     
  2. andrewoc thread starter macrumors newbie

    Joined:
    Sep 18, 2009
    #2
  3. andrewoc thread starter macrumors newbie

    Joined:
    Sep 18, 2009
  4. Blaine macrumors 6502a

    Blaine

    Joined:
    Dec 3, 2007
    Location:
    Abilene TX
    #4
    Maybe I can "kinda" help... Maybe

    I don't have one of the new ones, but I never liked the iMac speakers. My grandmother has the last gen iMac, and the sound is terrible on it in my opinion.

    Also, I recently bought a refurbished LED cinema display which also has speakers similar to iMac speakers and couldn't stand their sound either.

    Before you say I'm just being picky (probably true :p), I like the speakers on my unibody 15" MBP. Sure, the thing has no base, but the sound is crisp and clean unlike my grandmother's old iMac and the Cinema display's speakers.

    I think it may sound "muffled" to our ears because the sound isn't coming directly to our ears. It's bounced off whatever the iMac is sitting on and then comes to our ears.

    Try a test. Tilt the macbook display as far as it will tilt and then play something. This will point the speakers more directly toward your ears. See then if it sounds better.

    Let us know any updates, as I'm curious if you and I have the same kind of "ears" for sound. :eek:
     
  5. SmugMac macrumors regular

    Joined:
    Sep 25, 2009
    #5
    Odd.

    I have listened to audio on the 27" iMac at a local store and the audio was clear, loud - much improved over the previous iMac's.

    Perhaps it's the quality of the YouTube video? Play something from iTunes, how does that sound?
     
  6. mac88 macrumors 6502

    Joined:
    Aug 7, 2008
    Location:
    Boston, MA.
    #6
    Good advice on tilting the machine to test. It's worth a shot. Hopefully this is an easy fix. Good luck.
     
  7. andrewoc thread starter macrumors newbie

    Joined:
    Sep 18, 2009
    #7
    Nope, it's every youtube video, and iTunes sounds the same. Thanks.

    That seems like a pretty logical explanation, but it didn't work. The speakers on my old iMac were fine for my taste really. Thanks anyway :)

    Thanks :apple:

    This also makes it sound as if it's in slow motion. Calling apple today.
     
  8. HommePomme macrumors member

    Joined:
    Oct 28, 2009
    #8
    Just had the exact same problem last night on my 21,5. A reboot fixed the issue but it was troubling to say the least.

    I'll call up apple if it happens again.
     
  9. shakrooph macrumors newbie

    Joined:
    Oct 30, 2009
    #9
    Hi,

    I want to tell you that you probably have the same problem with most of the people who have a new 21.5 or a 27inch iMac. Youtube or other websites that require flash player peg the cpu usage to 100%-110%. The computer gets sluggish, videos get choppy and sound becomes what you show in the video.

    Rebooting the computer or reinstalling flash are temporary solutions. I have 21.5 inch with the ATI Display Card option and I have the same problem. You can check the forum here and find many similar posts.

    Let's hope that Apple will solve this with the upcoming Snow Leopard upgrade, otherwise there will be a riot here :D
     
  10. HommePomme macrumors member

    Joined:
    Oct 28, 2009
    #10
    Honestly, I thought it was this at first, but ran some flash tests (Youtube HD, etc) and have no issues. Activity monitor still shows 80%+ but no choppy sound or video. Fingers are crossed :p
     
  11. MacHamster68 macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #11
    the speakers are crap, you can listen to them but it wont be a pleasure, if you compare it with the iMac g3 ,which had the best speakers from all iMacs .. i can compare it a mate had bought a 27" imac
    and it sounds like i would have some of these in my ears
    [​IMG]




    my mate has after the problems with the uncomfortable mouse , the choppy flash issue the crap sound now returned the new 27 to pcworld within the 5 day return thingy and has bought himself a imac g5 for the time until apple will sort out all the probs
     
  12. indiekiduk macrumors 6502

    Joined:
    Jul 26, 2005
    Location:
    Glasgow, Scotland
    #12
    I loved the speakers on my 24" 2.4GHz alu imac. The 24" LED display is awful about half as loud as the imac and doesn't sound like it has a subwoofer at all. I tried the new 27" in the shop and it is just as bad low volume.
     
  13. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Joined:
    Dec 21, 2002
    Location:
    Yahooville S.C.
    #13
    The speakers are fine and in fact both have a separate 17 watt amp to power them, if they sound bad I would play with the settings, equalizer etc. No they arent bose 21.1.. but will do just fine for intended use. I have spoken.
     
  14. jzn21 macrumors newbie

    Joined:
    Nov 12, 2008
    #14
    I think I have the same problem with my 21,5" iMac it sounds the same as what you recorded! I describe this like stutter/clicking/interupts.

    I have the clicking sound when Skyping and browsing when the HD is active.

    Maybe it's worth to check the HD activity (like collecting data for Spotlight eg).
     

Share This Page