new 21" iMac, really slow wifi

Discussion in 'iMac' started by stormer13, Nov 10, 2010.

  1. stormer13 macrumors newbie

    Joined:
    Oct 12, 2009
    #1
    Hey guys,

    I just bought a new 21" iMac last week and the wifi has been very slow.
    Using speedtest.net I'm getting 3 Mbps (download) and my macbook pro (at the same location) gets 11 Mbps (download). Has anyone seen this issue? could it be an airport hardware problem?
     
  2. RRmalvado macrumors 6502

    Joined:
    May 27, 2010
    #2
    Have you tried unplugging your router from power for a few minutes and replugging it in?

    That usually solves most wifi issues.
     
  3. Spike88, Nov 10, 2010
    Last edited: Nov 10, 2010

    Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #3
    Try to following "tweaking":

    Was told many times that "some" Macs and wireless devices don't like WEP encryption. Change to WPA2 encryption instead. Some ISPs (like Bell Sympatico) ask their iMac clients to use WEP. Change router and iMac to WPA1 or WPA2 encryption. WPA2 is much better. For more details, surf: http://www.oit.umn.edu/wireless/setup-guides/osx-secure/index.htm

    Some wireless modems cannot "synch" to B & N signaling. As a suggestion, change router's mode to "only B". Sometimes, "only B" works better then having "B & N" configured.

    Also... Change default MTU within your iMac as well. This can be done by following MTU instructions within: http://forums.macrumors.com/showthread.php?t=1040516&highlight=mtu

    Perform these "tweaks" and advise how it works afterwards...

    .
     
  4. Kauai macrumors 6502a

    Joined:
    Oct 13, 2010
    #4
    Wouldn't switching to only B if you have the option of N cause a massive speed drop? B is quite old after all and I can't recall that many routers for it are even being made anymore outside of the backwards compatible ones.
     
  5. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #5
    Some routers models and iMacs cannot synch when using B & N configuraiton. Change to B only and "give it a try for a few days". If connection seems to be stable, then change to N only and "give it a try for a few days". Learn to walk before learning how to run things in life. Then, re-confugure router back to "B&N" (aka: mixed). If wireless connection drops down to a snail's speed, then one found the root cause of the problem. re: One's iMac doesn't like to "synch" with B&N on one's specific brand of modem. Its' gotta be B or N - but NOT mixed - like my wireless Router.

    Also... For general surfing / email, using "B only" is NOT a major speed drop difference. If download or data streaming (like playing Youtube videos), then one can see speed difference between B & N. For general email send/receive and doing forums (like this one), many people cannot tell if their client device is B or N connected.

    Hope these additonal details help....

    .
     
  6. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #6
    Forgot to mention....

    Couple more improvement ideas to help identify the slowness of your iMac:

    Within your iMac's Preference-Network-Advance settings, turn IP V6 to off. Many homes only use IP V4 (meaning, 4 digit set IP Addresses). Some Mac users turn this setting to off and it helps make their iMac's Internet access go faster.

    If connected to a Gateway/Hub that uses its own Firewall (like my physical router), then turn iMac Firewall off. If wondering, iMac Firewall is a software firewall.. I read somewhere that sometimes (rare but it can happen), firewall behind a Firewall conflict with each other. And, as some might say, don't synch with each other. Turn iMac Firewall OFF can help identify if Firewall problem (assume you already have Firewall on your home network).

    Try these items as well...

    .
     

Share This Page