new 27" i7 - sleep and screen dimming issues

Discussion in 'iMac' started by OldCorpse, Feb 4, 2010.

  1. OldCorpse macrumors 65816

    OldCorpse

    Joined:
    Dec 7, 2005
    Location:
    compost heap
    #1
    I may have an issue with my new i7. It doesn't seem as if the sleep and screen dimming functions are working properly. Here's the problem. I want to watch a movie, or run a program like Eno's "77 million paintings" - this requires that the screen not suddenly dim, or the computer go to sleep. So what I do, is:

    1)Go to System Preferences and in Energy Saver, set "Display sleep" to 3hrs, and "Computer sleep" also to 3 hours.

    2)In Desktop & Screen Saver, I set the "Start screen saver" to NEVER.

    Then I watch the movie or run Eno's program. BUT then suddenly and randomly the screen will dim way before the 3 hours. With Eno's program, it first dimmed, and then later it actually went to sleep right in the middle of the show!

    I checked the temps with iStat, and they are never above 55 - at least that I saw. If I operate the computer normally, surf the web etc., I never have it suddenly go to sleep on me... but when I run Eno's program it did.

    What's the deal here?
     
  2. MMM.PWR macrumors 6502

    MMM.PWR

    Joined:
    Sep 21, 2009
    Location:
    Chicago
    #2
    I don't know why the computer would just go to sleep if you have it NOT to go to sleep. As far as the dimming goes, make sure the Automatically reduce brightness before display goes to sleep box is unchecked in Energy Saver Prefs.
     
  3. OldCorpse thread starter macrumors 65816

    OldCorpse

    Joined:
    Dec 7, 2005
    Location:
    compost heap
    #3
    OK, I'll try that - though my understanding is that it dims only right before (a few minutes) the display and/or computer goes to sleep. If I have it not go to sleep for 3 hrs, it shouldn't dim until right before the 3 hrs elapses, and not like 30 minutes into the movie... no?

    Anyhow, I'll try that - I'm off to watch a movie, and I'll check in on the thread after that. Thank you!
     

Share This Page