New 27" iMac deadly slow in accessing folder contents

Discussion in 'iMac' started by psybear, Dec 30, 2012.

  1. psybear macrumors newbie

    Joined:
    Jan 16, 2012
    #1
    First iMac and I'm loving lots of things about it (spec as per signature) but now that I've finally got it close to the stage where I can start to do some photo editing on it, I am getting really frustrated at the length of time it takes to access sub-folders in my photo library. It's just taken TWO MINUTES to display the contents of a pictures folder on my hard drive. This would've been instantaneous on my old PC (even if said PC started to creak and run slowly once I started to use Lightroom).

    This can't be right surely, not on a machine of this spec? Everything else runs super-smooth. Sub-folders can be very slow to open directly within Finder but the problem is definitely far worse if I'm trying to open within Photoshop.

    Any help/advice appreciated.
     
  2. Paulywauly macrumors 6502a

    Paulywauly

    Joined:
    Sep 26, 2009
    Location:
    Durham, UK
    #2
    That doesnt sound right at all. Have you tried going into the Disk Utility > First Aid to check your permissions and repair disk?
     
  3. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #3
    Thanks for the suggestion. Tried that. No problems found with the disk. Some of the permissions were off and it fixed them, but the problem persists.

    I just tried a restart to make sure that there was nothing else interfering. I haven't managed to replicate the two minutes, but the access times are still awful. These are subfolders containing a mixture of RAW and jpeg picture files, nothing else. There seems to be a connection between the size of the folder contents and the length of the access time, but it's inconsistent:


    15 secs to access a 14GB folder
    5 secs to access a 4GB folder
    30 secs to access a 23GB folder
    20 secs to access an 11GB folder
    12 secs to access a 5GB folder
    25 secs to access a 3GB folder
    10 secs to access an 11.5GB folder
    14 secs to access a 5GB folder

    By access I simply mean to see any icons appearing - until something appears in the otherwise blank space!

    Any other suggestions welcome... I'd hate to have to pack the whole thing up and carry it into a Genius bar, but I didn't pay 1800 quid for this crap performance... :(
     
  4. Paulywauly macrumors 6502a

    Paulywauly

    Joined:
    Sep 26, 2009
    Location:
    Durham, UK
    #4
    That is odd. I have a new base mini with an 5200rpm hard drive which isn't half as fast as yours but I have folders full of hundreds of GB worth of stuff that appear right away. I'd take it back to Apple to look, there is defiantly something wrong
     
  5. Apple Corps macrumors 68030

    Joined:
    Apr 26, 2003
    Location:
    California
    #5
    Has Spotlight completed the indexing process?
     
  6. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #6
    This is where I really show my ignorance of OSX - how can I tell?
     
  7. 12dylan34 macrumors 6502a

    Joined:
    Sep 3, 2009
    #7
    Click on the magnifying glass icon in the upper right. If it's indexing, it'll say so in the dropdown.
     
  8. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #8
    Nope, nothing there but the search box.
     
  9. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #9
    There is a bug in the latest version of ML that causes spotlight to continually index. That may be causing issues. It is on my system.
     
  10. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #10
    But surely I would then see that it was indexing? At no stage since I got the iMac (about 10 days ago now) have I noticed any indexing going on.

    I did have problems in transferring over my photo library from an external HD onto the main drive - but I thought that this had been resolved.

    I'm reading up on Spotlight now and I'm wondering if I should try to force a re-indexing as per here: http://www.itworld.com/software/217685/force-spotlight-re-index-your-hard-disk-mac-os-x-lion
     
  11. spacepower7 macrumors 68000

    Joined:
    May 6, 2004
    #11
    If you have the Finder view options to set to "Calculate all sizes", this could also slow things down.

    Another thing:

    If you have external drives (especially USB), when you try to open a file from Photoshop, LightRoom, etc... (not just Adobe apps) File>Open dialog box... The OS stalls until all mounted external drives wake up, even if the file you want is on the internal drive.

    Hope this helps
     
  12. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #12
    Thanks for the suggestion but this was already unchecked.

    Yeah i noticed that my external 2TB drive was spinning up when I went looking for pictures (I think it was actually doing this even when I went straight into Finder?) and disconnected it early on in the checking process, so that's it ruled out.

    I did a series of tests on the same set of sub-folders to see how consistent were the results and how the time taken to access was related to the size of the sub-folder. Whilst there are some inconsistencies, there is a definite correlation between size and 'read' time. I rebooted between each test as, once the subfolder has been read, the contents display (more or less) instantaneously on subsequent access attempts - until the reboot, which resets the problem.

    Folder size first (GB), followed by read time in seconds (three tests):

    12.4 - 11/11/12
    11.5 - 10/8/9
    3.5 - 6/6/5
    4.7 - 7/4/5
    2.9 - 10/5/3
    13.7 - 21/12/13
    4 - 30/4/5
    5 - 13/6/5
    10.8 - 21/11/9
    5 - 18/7/7
    23.5 - 41/26/28
    10.6 - 10/10/9
     
  13. Acorn macrumors 68020

    Acorn

    Joined:
    Jan 2, 2009
    Location:
    macrumors
    #13
    this should not be happening. My art folder is 225 gigs and resides on my macbook pro. If i access that folder with my mac air over my network via sharing the contents of the folder (25 sub folders totaling 225 gigs) is still instantaneous. surely this should be slower then what your doing.
     
  14. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #14
    Booked into local Genius bar on Thursday. Tried accessing telephone support but it's closed today. :(
     
  15. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #15
    You wouldn't happen to have installed a file sharing service like Insync? Dropbox?

    Do you have finder set to list view? (try icons or columns)

    You didn't install some type antivirus program?
     
  16. psybear thread starter macrumors newbie

    Joined:
    Jan 16, 2012
    #16
    I think I'm sorted now after a 57 minute phone call with support, which was open after all. :)

    Problem identified as non-hardware related after a safe mode reboot revealed everything was readily accessible. Four possible culprit applications at start-up and it seems that Crashplan was the culprit. I installed it almost immediately on getting the machine and had noticed that, although running, it was making zero progress in actually backing up my files - so it was obviously causing some sort of conflict.

    So relieved I don't have to lug this beast into the local Apple store! :D

    Thanks for all the suggestions folk, it did actually shorten my time on the phone as I was able to say 'no I've tried that' to several suggested solutions before he hit on the real problem.

    And full marks to those telephone support folk - they were really excellent. The guy that I was escalated to has given me a direct line in the event of any further problems.
     
  17. BSoares macrumors regular

    Joined:
    Jun 22, 2012
    Location:
    USA
    #17
    Hmmm, I've used Crashplan before and was planning on installing that again on my new 2012 iMac. Did you attempt a reinstall or you'll go w/o a backup for now?
     
  18. lali macrumors regular

    Joined:
    Oct 14, 2007
    #18
    Now that makes sense. How do you like the responsiveness of the computer now?
    Happy you resolved it
     

Share This Page