New 27" iMac display adapter problem?

Discussion in 'iMac' started by Stealthipad, May 3, 2010.

  1. Stealthipad macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #1
    I am on my new 27" iMac last night when all of a sudden the display froze and pix-elated for a second and then went black and a few seconds turned back on with an error message at the bottom right screen saying my display adapter had stopped . . . . .

    I was in Windows 7 64bit Professional at the time. I also noticed that Apple is wanting download a newer version of Boot Camp which I will download tonight!

    I went to the ATI website and found a new driver dated 4-2010 and downloaded it. All seems well but was wondering if anyone has had the same issue?:confused:
     
  2. Blathian macrumors member

    Joined:
    Nov 4, 2007
    #2
    hey stealth, having same issues and havnt got help...when you download the ATI drivers...are you getting radeon Mobility or regular drivers? and did they fix your problem?
     
  3. Stealthipad thread starter macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #3
    I downloaded and installed the latest ATI driver for my 27 iMac video card for WIn7 64bit. It was dated 4-2010. I had also downloaded the newest Boot Camp. After using for near 4 hours late night, I did not have any more problems.

    I hope that this is it as I love my now "perfect" 27" iMac:p
     
  4. spcdust macrumors 6502a

    spcdust

    Joined:
    May 6, 2008
    Location:
    London, UK
    #4
    Can you confirm what ATI driver version you are now running? Also, did you do this just by going into the drivers properties and clicking the update driver button?
     
  5. Stealthipad thread starter macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #5
    It was from the ATI website. Dated 4-2010. Version 10.4.0.0, I think

    Not a single blink from my ATI adapter after the install.
     

Share This Page