New 27 inch i7, Windows 7 and Bluetooth

Discussion in 'iMac' started by wfj5444, Nov 15, 2009.

  1. wfj5444 macrumors 6502

    Joined:
    Jul 2, 2008
    #1
    I know that Windows 7 is not officially fully supported yet but I have been having some strangeness with my BT devices.

    My wireless Apple keyboard and Magic Mouse sync'd with out any issues or even having to pair them when I first installed Windows 7 x64, and then the Bootcamp drivers.

    Since then it has been hit or miss on the mouse, and it never works on the KB. I cannot pair either of them. They both always show up as paired, but only the mouse works and then rarely. I noticed it seems to stop working anytime I plug in another USB device.

    Anyone have any thoughts? I have removed the BT drivers from Apple trying to get one from Windows Update but no luck there. I have extracted the new BT update for Windows from Apple and that seemed to help just a bit.


    The strangest thing is that it worked at first and never again :\
     
  2. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
    #2
    Happened to me on a 2006 iMac actually as well. Keyboard worked fine during install, and up until the BootCamp drivers were installed. Once they were on, Windows 7 would simply not connect the keyboard.

    I put this down to Win7 and BootCamp not being supported yet, and I think Apple needs to do a bit of driver tweaking. Annoying though.
     
  3. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #3
    I have never been to consistently get Bootcamp'ed Vista to work with my Bluetooth keyboard. My Bluetooth MS notebook mouse works 95% of the time. When it doesn't I disable and enable the the Bluetooth in the Device Mgr and it usually comes back. If not a reboot usually resolves the issue. These issues happen on my uMBP and our 1st Gen MacPro both in Windows Vista.

    Cheers,
     
  4. wfj5444 thread starter macrumors 6502

    Joined:
    Jul 2, 2008
    #4
    Unfortunately, I can't seem to do much to make it work anywhere near 95% of the time. I get around 50% with the mouse as long as I don't plug in an additional device.

    Since I don't have anything on this Windows partition yet, I might reinstall it and see just exactly when I loose everything. Is it after BC? Is it after BC + Windows Update, etc..

    Thanks :)
     

Share This Page