New 60W MagSafe Power Adapter doesn't work.

Discussion in 'MacBook' started by x00JuGGiE00x, Oct 10, 2010.

  1. x00JuGGiE00x macrumors newbie

    Jan 7, 2010
    I recently bought a new charger called the 60W MagSafe Power Adapter, for some reason for the first time when I plug it into my Leopard Macbook, it works. But when I take it out and plug it back in, it doesn't seem to charge. I would have to remove my battery and place it in again for the charger to charge my macbook. I don't think the charger is the problem because it charges on my macbook Tiger fine. It's only my leopard macbook that has a problem.
  2. youno macrumors newbie

    Jul 1, 2010
    Is your macbook an 07 or 08 model? if it is there's a firmware update available to correct the battery charging issue.
  3. x00JuGGiE00x thread starter macrumors newbie

    Jan 7, 2010
    I'm not sure about the model, but it is an ordinary macbook and not the "Pro" model. It is white and I ordered it in 2008, the resolution supports max at 1280x800, the Version is 10.5.8 and on the bottom of "About this mac" says TM & © 1983-2009 Apple Inc. But at the bottom of my macbook says TM & © 2007 Apple Inc.
  4. firsttimeposter macrumors newbie

    Dec 31, 2011
    a simple temporary fix that worked for me

    --seem to have an older model of macbook pro 13 inch. worked perfectly with its original power chord of course.
    --original power chord was fraying
    --bought from apple store the 80 dollar 60w magsafe power adapter
    --walked miles home, didn't work. walked miles back, returned and got cash back (not trying to get their help, since i knew of replacements from non-apple vendors)
    --original power chord finally frayed through
    --researched replacements on amazon from non-apple vendors, bad reputation
    --went back to apple store, got appointment with genius to ensure new product worked with my computer before taking it out of store.
    +they plugged my computer into their standby power chords (scattered throughout their store)...didn't work.
    +then did work.
    +then new power chord from unopened box worked.
    +since it didn't work at first, he did several diagnostics.
    +SIGNIFICANT: during one of the steps above, and the genius and i thought nothing of it at the time, the genius turned the computer over, removed the battery (to get the serial number?), and then he simply reinserted it.
    --i was happy cuz my new power chord worked.
    --worked at home!
    --then DIDN'T WORK at a later date
    --came on these boards, and tried the firmware referenced above. DIDN'T HELP. my computer said i didn't need the update

    --i was desperate, power was low. so i tried what the apple guy tried (to find the serial number). i shut down the computer. i turned it upside down. i turned the screw thing (clockwise!) with a quarter. i took out the battery. i did nothing to it. i just put it back in. rescrewed. turned everything back on...AND IT WORKED!

    long story short, and this might be a TEMPORARY FIX ONLY: if everything doesn't work, try just shutting down; turning computer upside down; unscrewing screw (clockwise); taking out battery; doing nothing; putting battery back in; rescrewing. turning computer back on

    this could have to be RE-DONE EVERY SINGLE TIME the chord don't work

    but i don't care

    if this fixes the problem temporarily every time the chord don't work, i'll do it (despite the inconvenience). i just don't trust the non-apple vendors (given reviews on amazon). and i kind of don't trust that apple can fix this compatibility problem.

Share This Page