New Airports/Time Capsules require OS X Lion. Doh!

Discussion in 'Mac Accessories' started by ftaok, Jun 10, 2013.

  1. ftaok macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #1
    Just checked the tech specs on the new extreme. Looks like you'll need a Mac with Lion or newer to set it up using a computer. No more Windows setup.

    My problem is that our Mac is stuck on Snow Leopard.

    We do have multiple iOS 5+ devices, so I can still get this. Anyone know if the iOS airport utility lacks features that the Mac Airport utility has?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I saw there was an iOS Airport Utility update today to support the new deivces, so it looks like you could configure with an iOS device then still use the new router with any existing client machines you have.
     

Share This Page