New alu keyboard - volume keys do not work

Discussion in 'Mac Accessories' started by maflynn, Aug 17, 2011.

  1. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #1
    My aluminum keyboard that I had hooked up to my MBP died, due to a self-inflicted action (too much liquid on the keyboard when cleaning it).

    Anyways I bought a new one, lo and behold the volume keys do not work.

    Either by pressing the F11/F12 keys or pressing FN+F12. I tried setting/resetting the use all F1, F2 etc keys as standard function keys in the keyboard preference to no avail.

    I tried zapping my PRAM but that failed as well.

    What the keyboard preference appears to be doing is setting the keyboard preferences for my MacBook Pro's keyboard. Selecting the keyboard shortcuts tab and then selecting internal vs apple keyboard does not help either.

    Now if I plug in my old partially non-functioning keyboard the volume keys work as I expect them too, but not the new keyboard.

    Any suggestions or help?

    This is on a 13" MacBook Pro, running 10.6.7
     
  2. Lennyvalentin macrumors 6502a

    Lennyvalentin

    Joined:
    Apr 25, 2011
    #2
    You appear to have exhausted most of what one can reasonably expect to try to remedy your situation. For curiosity's sake you could try plugging your new keyboard into a different computer just to see if the keys work then.

    In any case it sounds like you need to get your keyboard replaced.
     
  3. maflynn thread starter Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    I tried the keyboard on a Mac Mini and the same exact issue occurred.

    I open up the virtual keyboard and I see the keys being pressed, that is f11 and f12.

    My wife works across the street to an apple store so she replaced the keyboard and gave me a new one. That is producing the exact same phenomenon. Given that I purchased the first keyboard at a different store, the odds are high this replacement one is from a different lot so I don't think two keyboards from different manufacturing lots would be defective in the same exact way.

    To summarize, my old alu external keyboard's function keys work, but none of the new alu keyboards do when I want to use them for volume, brightness (f1/f2) that is FN+F1. I see the FN key being depressed in the virtual keyboard.

    I'm going to search out some plists and purge them to see if that fixes it.
     
  4. essess27 macrumors newbie

    Joined:
    Dec 21, 2010
    #4
    I have the exact same problem. Tried exchanging the keyboard like you did, same thing. Neither volume nor brightness keys respond, holding Fn or not... please post the solution if you find one! Thanks!!
     
  5. sixolightning macrumors newbie

    Joined:
    Sep 23, 2011
    #5
    same problem here. i might have some light to shed on the issue. just bought a new keyboard today, as my old one lost three buttons (space, tab, fn) to too much cognac.

    im on os x 10.5.8, and the keyboard manual tells me to upgrade to 10.7 or later for the keyboard to function to its full range of features.

    i have tried all the remedies you have, and exactly the same applies to me. does your keyboard manual say anything about upgrading the os? because mine does, and im a bit livid really, now i may have to purchase the bastard 10.7

    the question is, isn't there any other way to get vol.up/vol.down functions on the keyboard, without paying 29.99???
     
  6. maflynn thread starter Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    I'd agree to that, for some reason the keyboard didn't but after upgrading to 10.7 those keys I complained about mysteriously started to work again. I forgot about this thread which is why I didn't return back - my bad.
     

Share This Page