New Aluminium iMac Problem: Firewire 400

Discussion in 'Mac mini' started by Shreedhan, Sep 7, 2007.

  1. Shreedhan macrumors newbie

    Joined:
    Aug 28, 2007
    #1
    Hey guys,

    I got a new imac and I have a problem with my FW400.
    In system profiler under "Firewire" it says:

    "
    FireWire Bus:

    Maximum Speed: Up to 800 Mb/sec
    "
    My Western Digital MyBook Premium doesn't connect via FW400. It's got me quite worried since I've only had it for a couple of days. I've tried resetting PRAM, the SMC wit no avail.

    Any ideas?
     
  2. mzd macrumors 6502a

    Joined:
    Jul 25, 2005
    Location:
    Wisconsin
    #2
    all i can offer is that mine says the same thing in profiler and my 3G iPod connects perfectly (firewire 400).
     
  3. rainydays macrumors 6502a

    Joined:
    Nov 6, 2006
    #3
    My WD MyBook Premium works fine. Did you try updating the firmware on the MyBook? If that doesn't work, try finding another FW-device to test.
    If that doesn't work, return your iMac.
     
  4. AlexisV macrumors 68000

    AlexisV

    Joined:
    Mar 12, 2007
    Location:
    Manchester, UK
    #4
    I don't understand. Is it FW 400 or 800? How doesn't it connect?
     
  5. oduinnin macrumors regular

    Joined:
    Aug 3, 2007
    Location:
    Planet Earth
    #5
    The new Aluminum iMac has both 400 & 800 connectors. If your WD HD has both connectors & cables, as my LaCie does, you should be able to connect up using either cable and get the appropriate speed.

    In doing online research into which external drive to get, I noticed that one of the WD drives I looked at (because it offered both FW 400 & 800), did not offer the FW 800 when used with a Mac. Why, I haven't a clue, except I've also noticed that WD products seem to be Windows oriented.

    Shreedhan, What happens when you connect up using FW 800 cable? if available.
     
  6. Shreedhan thread starter macrumors newbie

    Joined:
    Aug 28, 2007
    #6
    Right, I borrowed my firends old U2 iPod which can connect via firewire (unlike the newer ones) and it connected fine, showed up on desktop and in iTunes with all of it's info.

    I tried a spare cable I had with the MyBook again but still no luck.

    I googled and found lots of people with same/similar problems:

    http://discussions.apple.com/thread.jspa?messageID=5280624

    http://forums.macrumors.com/showthread.php?p=4145769

    this sucks because I have my new iMac setup the way I like and if i have to return it i have to do it ALL over again!
     
  7. Kinetic macrumors member

    Joined:
    Jun 29, 2007
    Location:
    NC
    #7
    I have the same problem (although I have the MyBook with the USB and Firewire 400 connections). The USB works fine, but the FW doesn't. I tried another FW drive and it works fine. It must be something with the MyBook. For now, I have it running on USB. I'm going to check to see if I need to update the firmware next, but I would like to know what's going on.
     
  8. mucmacian macrumors newbie

    Joined:
    Aug 15, 2007
    #8
  9. Shreedhan thread starter macrumors newbie

    Joined:
    Aug 28, 2007
    #9
    It's definitely a WD problem since my camcorder works fine with the FW400 port, I want them to sort it asap.
     
  10. Leon Kowalski macrumors 6502a

    Leon Kowalski

    Joined:
    Sep 20, 2007
    Location:
    Gondwanaland Reunification Front HQ
    #10
    Sure sounds like a WD problem; my two IcyDock external enclosures (one
    each FW400 and FW800) both work fine on the iMac's FW400 port. The WD
    "MyBook Premium" firewire port is FW400-only, so it should work -- but
    there have been many complaints of iMac problems with the entire MyBook
    product line.

    LK
     
  11. twighlitediter macrumors newbie

    Joined:
    Jan 16, 2008
    #11
    Have you tried repairing your disk permissions? I recently bought a Lacie and after a few days, the drive was connected, but it didn't show. Repairing permissions did the trick for me.
     

Share This Page