New AMD GPU Driver OMEGA - Working@Bootcamp

Discussion in 'iMac' started by TerrorOFdeath, Dec 8, 2014.

  1. TerrorOFdeath, Dec 8, 2014
    Last edited: Dec 11, 2014

    TerrorOFdeath macrumors member

    TerrorOFdeath

    Joined:
    May 15, 2008
    #1
    Here we go Lads and Gents:

    New AMD Driver Omega. !!Still NO 5K Resolution!!.

    http://www.guru3d.com/articles-pages/amd-catalyst-14-12-driver-the-omega-driver,1.html

    http://www.pcworld.com/article/2856...nvents-amds-approach-to-graphics-drivers.html

    For those how know German:

    http://www.computerbase.de/2014-12/amd-vsr-nvidia-dsr-downsampling-catalyst-omega-vergleich/

    Gonna testem after Work, stay Tuned.

    Tod
    ******
    !!!EUREKA!!!
    *************************************************************************************
    Here we go:

    Fist of all I need to say following. Everything you do, you are doing it at your own Risk. I will not be hold responsible for any Damage this may cause.
    Installation was done on Windows 8.1. The Installation Process may vary by your Version of the OS. Also I have the M295X. I cannot say how other Cards will behave.

    Step 1:

    You have to download the Omega Driver from the AMD Site and extract everything. After that, go to the folder "\Packages\Drivers\Display\WB6A_INF". There ist the "CU178000.inf" File, which we need to edit first.
    Search for following String: ""%AMD6939.1%" = ati2mtag_Tonga, PCI\VEN_1002&DEV_6939&REV_00" and replace it with ""%AMD6939.1%" = ati2mtag_Tonga, PCI\VEN_1002&DEV_6938&REV_00", then save the file.

    Now you need to create a new "CU178000.cat" file. For that you need to download the "Windows Driver Kit 8.1 Update 1" from Microsoft and install it.
    After Installation you should have in the folder "C:\Program Files (x86)\Windows Kits\8.1\bin\x86" a EXE called "inf2cat"

    Create a new Folder directly under C: lets say TEST. Copy from the extracted Omega Driver Folder "\Packages\Drivers\Display\WB6A_INF" 2 things to C:\TEST: "CU178000.inf" and the Folder "B178093".

    Open a CMD as Admin and navigate to the folder: "cd C:\Program Files (x86)\Windows Kits\8.1\bin\x86"
    Execute this line: inf2cat /driver:C:\TEST /os:8_X64
    Now in your TEST Folder you have "CU178000.cat"

    Step2:

    Now we want to Install the Driver. But the Windows Driver Signature Verification, wont allow that
    First open up againe a CMD Console as Admin and execute 2 commands:
    "bcdedit.exe -set loadoptions DDISABLE_INEGRITY_CHECKS"
    "bcdedit.exe -set TESTSIGNING ON"
    Then go to the Advance Boot Option. Everything else can be found online, there are plenty of good Step-by-Step "Howto Disable Driver Signature Verification".
    You are going to Restart and then you will be in Windows but without the Restrictions.

    Now you have to download a Tool: "Driver Signature Enforcement Overrider".
    Againe, go Google it, im not providing Links.
    Start that up as Admin, and choose 2 Options: "Enable Test Mode" and "Sign a System File"
    When you choose the option "Sign a System File" it asks you for the location. -> C:\TEST\CU17800.inf. Do the same to "C:\TEST\CU178000.cat"

    After that open the Windows Device Manager. Go to Display Adapter and open the Entry inside. Go to "Driver" and choose "Update Driver". "Browse my computer for driver software", "Let me pick from a list of device drivers on my computer", "Have Disk...", "Browse" and the go to "C:\TEST\" and choose "CU178000".

    It should recognize your Card as "AMD Radeon R9 200 Series". Install and reboot.

    Finale

    Now you should have rebooted without any problems and the driver should be installed just fine as in my Screenshot. Check the Device Manager!
    I should note, that i did this on a clean Installation without any GPU Drivers installed. I only Installed afterwards the Catalys Software that came with Bootcamp, but without the DisplayDriver.
    Maybe you can do it without deinstalling the old Drivers. Just test

    Tod

    *************************************************************************************
     

    Attached Files:

    • 1.JPG
      1.JPG
      File size:
      297 KB
      Views:
      1,878
  2. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #2
    I tried to install to iMac 5k with r9 295x but failed. I can't install any driver except the stock boot camp drivers from Apple. Windows 8.1. If you know any other way let me know please.
     
  3. TerrorOFdeath thread starter macrumors member

    TerrorOFdeath

    Joined:
    May 15, 2008
    #3
    Will do. Right now i started work, its 0700AM here in Switzerland^^ So its gonna be a while til 1600PM :)

    I should be able to make it work, will post an Instruction if I succeed. (Maybe someone is faster ;))

    Tod

    ----------

    You are 100% sure, that these dont work vagos?

    http://www2.ati.com/drivers/amd-catalyst-omega-14.12-with-dotnet45-win8.1-64bit.exe

    Tod
     
  4. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #4
    The link that you gave me take me to amd page and writes "Download Not Complete
    ​Review the guide below for solutions to download your file

    We’re sorry, but we were unable to complete your download. There could be several reasons for this:
    You were linked to this download from a site outside of AMD.com
    Since we do not allow downloads through sites outside of AMD.com, please download your file directly from our site. We want to make sure you have the right driver for your device and operating system. Choose your product and operating system on the AMD Driver Download page or use the AMD Driver Autodetect to obtain the correct driver for your device.
    You copy and pasted the download link or clicked “Save As”
    When you copy and paste a link or right click on it and select “Save As,” your browser will not send a referrer and our site will not allow the download. Please click the Back button in your browser and simply click the link instead.

    Now I can't install the bootcamp driver. It gaves me error that doesnt install the audio driver

    ----------

    this is the log : boot camp drivers :
    Catalyst™ Install Manager
    Installation Report
    12/09/14 02:23:50


    Hardware information

    Name Unknown
    Manufacturer Advanced Micro Devices, Inc.
    Device ID 0x6938
    Vendor ID 0x1002
    Class Code 0x030000
    Revision ID 0x00
    Subsystem ID 0x013a
    Subsystem vendor ID 0x106b
    Other hardware

    Existing packages
    AMD Catalyst Install Manager

    Packages for install
    AMD Catalyst Install Manager
    Final Status: Success
    Version of Item: 8.0.915.0
    Size: 20 Mbytes
    HDMI Audio Driver
    Final Status: Fail
    Version of Item: 9.0.0.9903
    Size: 1 Mbytes


    Other detected devices


    Manufacturer Advanced Micro Devices, Inc.
    Device ID 0xaad8
    Vendor ID 0x1002
    Class Code 0x040300
    Revision ID 0x00
    Subsystem ID 0xaad8
    Subsystem vendor ID 0x1002


    Error messages

    Driver Install: the specified driver package was not installed for matching devices
     
  5. TerrorOFdeath thread starter macrumors member

    TerrorOFdeath

    Joined:
    May 15, 2008
    #5
    Strange..

    Heres the Link where you can click on Download:

    http://support.amd.com/en-us/download/mobile?os=Windows 8.1 - 64

    Alltough i just saw the following:
    "This driver is not intended for use on AMD products running in Apple Bootcamp platforms. Users of these platforms should contact their manufacturer for driver support."

    However, I would try only to install the Graphics Driver not the other stuff. You can install the other stuff later or even the older version of the HDMI Audio. Jeez i want to go home to start testing^^

    Tod

    ----------

    Dont forget. For every time you want to install a new Driver you have to deinstall and Clean everything of old Drivers. Use this tool:

    http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

    Tod
     
  6. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #6
    we are unable to find a driver for your system. no supported amd hardware was detected. I think I am gonna reinstall windows. maybe I am gonna try windows 10
     
  7. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #7
    The R9 M295X is an Apple-only card (for now, that is).

    Apple was the first (and still is the only) vendor to ship the R9 M295X in their products. So there aren't any Windows drivers for it yet.

    The M290X has Windows drivers for it because it's based on the existing Pitcairn architecture.

    The M295X uses the new Tonga architecture.
     
  8. Pressure macrumors 68040

    Pressure

    Joined:
    May 30, 2006
    Location:
    Denmark
    #8
    Sure there are, it's the exact same chip as the Radeon HD 285 based on Tonga.

    You might just need to install it manually.
     
  9. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #9

    You have right. I tried everything nothing so far. I reinstall and I put windows 10 preview I unistall the bootcamp driver I tried to install the omega but nothing . Hopeless. I guess I have to wait. How is the performance on games on windows 10 comparing to 8.1? I tried x-plane and it seems slower than 8.1. I am gonna try some other games.

    ----------

    I tried manually but says that I have the most new driver. I tried from the device manager and right click on the driver and update and browse. Except if you know another step by step procedure.
     
  10. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #10
    The drivers do not currently have the matching device strings in the .inf file to install the drivers right now. I would be patient as I reckon for 5k support in Windows Apple must be testing this driver out right now and will be released in the future update within weeks or a month.

    Though it isn't difficult to add the strings into Windows drivers, it just breaks the digital signing doing it and be aware you might get blue screen hell using it!
     
  11. kfscoll macrumors 65816

    kfscoll

    Joined:
    Nov 3, 2009
    #11
    FWIW I tried to install this new AMD driver on my Mac Pro with dual D700s and got the same error as others have mentioned:

    We are unable to find a driver for your system. No supported AMD hardware was detected.

    I've rolled back to Catalyst 14.11.2 for now and will keep my eyes open for a newer version of the Omega driver.
     
  12. Ironjer macrumors regular

    Joined:
    Jul 18, 2013
    #12
    Currently we are discussing it here:

    http://forums.macrumors.com/showthread.php?t=1827070
     
  13. TerrorOFdeath thread starter macrumors member

    TerrorOFdeath

    Joined:
    May 15, 2008
    #13
    So..

    Well, first of all yjchua95 please dont say such nonsense if you have no Idea hav Things work others may get the wrong Idea and simply give up. Vagos, dont get discouraged :)


    You have to download the Omega Driver and unpack the whole Thing. In there is an Folder named Bin64. Now you have to have the old DriverPackage that came with Bootcamp Drivers.


    In the Bin64 Folder from the old Package, you have to copy 2 Files in the new Bin64 Folder and replace them:
    - InstallManagerApp
    - InstallManager.dll


    Now the Installation starts.


    However, after searching for an GPU it crashes. At least for me. The Driver with the m295X ist located in the Omega Folder: OMEGA\Packages\Drivers\Display\WB6A_INF\CU178000.inf


    When I try it to install only the Driver, it says wrong Windows Version. Now that may be because I use Win10TP.


    Would love to hear what happens for others, does it also Crash? Ah yeah - You have to have allready installed the Bootcamp Driver. Otherwise it wont recognize the AMD GPU.


    Tod
     
  14. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #14
    I already install the windows 10. I install also the bootcamp drivers. Do I have first to remove them with the program that you suggest it or to make like this the installation?
     
  15. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #15
    Bearing in mind of the warning specifically about bootcamp I would imagine that BSOD and problems will occur if you try to get this going on an iMac 5K with its overclocked DP connector. On a Mac Pro 6,1 running a 5k Dell with twin DP connections I would hazard a guess this Mac may be slightly less of a nightmare than the 5k!
     
  16. acuraice macrumors newbie

    Joined:
    Dec 9, 2014
    #16
    Got it to install successfully!!

    I awoke this morning to see the new AMD omega driver release info and i also saw the note that said not intended for apple bootcamp.

    I tried to install the updated omega driver with the older amd auto detect tool, it found the omega driver yet when i clicked download it through the error the connection to the server was disconnected abnormally.

    I have never sent his error before in all the years i have been updating my imacs running bootcamp with the amd auto detect tool.

    I then went to the amd website and downloaded the newer auto detect utility(no longer called auto detect tool)

    When i ran the newer auto detect utility, a new error came up saying no amd hardward can be found, even though it clearly showed my amd radeon 6900 series, intewl i7 2600k and windows 8.1 operating system all grayed out.
    I knew now that this was only a cheap setting by amd to prevent the install of the omega driver for users like myself using apple bootcamp.
    Even though we are all perfectly capable of running any desktop or mobility drivers as in the past with our bootcamp setups.

    My next step was to download the amd omega 14.12 driver package from manually selecting my gpu on the amd drivers support page.
    http://support.amd.com/en-us/download

    Now when i tried to install with the newly download catalyst 14.12 package file thingy on my desktop, it gets all the way to the end of the unpacking stages and says no amd hardware can be found. again pure ********.

    After reading this forum post and seeing others having problems getting it to install. I decided to poke around in the AMD folder.

    If you follow what i am saying and get the packages to unpack to your C drive in the folder labeled AMD, simply go to that folder and click through the folders starting with packages, then drivers, then display, then WB6A_INF, then click the "CU178000" installer to get it to run. Immediately a popup will come up saying that you need to install the latest catalyst manager in order to run the display driver installer. I choose "yes" and then the catalyst installer opened as normal. I choose express and let it do its thing. Boom!! I now have the latest driver for my apple imac running windows 8.1(latest updates) and an amd radeon 6970m or as windows has it in the device manager , the amd radeon 6900 series.

    I am now running the latest driver from the omega package. See the attached screenshot below:

    Now if i run the older auto detect tool it confirms i have the latest driver like it should. If i run the newer auto detect utility not the older tool, it still says no amd hardware found. So we can all see that the newer utility is simply blocking the install bc we are on apple's bootcamp. The older tool functions as it should now that i got around the connection disconnect abnormally error. Long story short i have the latest omega driver running and working perfectly. Not sure about how it will improve my fps while running games like far cry 4, but many others have posted videos on youtube showing a tiny increase in fps as well as power consumption being decreased slightly.

    My imac's specs are below:
    3.4 ghz quad core i7 2600k 27 inch imac
    16 gigs of 1333 mhz ram
    windows 8.1 (latest everything)
    amd radeon 6970m (2 gig version)
     

    Attached Files:

    • amd.PNG
      amd.PNG
      File size:
      52.1 KB
      Views:
      631
  17. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #17

    Did you first unistall the bootcamp drivers before you procedure the install?
     
  18. acuraice macrumors newbie

    Joined:
    Dec 9, 2014
    #18
    no i did not. nor have i ever uninstalled any previous amd drivers before updating to newer updated amd drivers. I simply run the auto detect tool and if there's an updated driver i follow the directions throughout the installer. I always choose custom and install just the display driver and hdmi audio drivers. sometimes the catalyst manager thingy which i never use. ALL of my pc games run perfectly except for some buggy ones which i have to tweak to get running the way i want them to.

    These nonsense errors are just put in place by AMD for whatever reason so they can throw their hands up when it comes to apples bootcamp. Our system have and will always be capable of running any amd driver with our amd cards.

    My procedure for getting the driver to install on my particular system may or may not work for yours,but im pretty sure it will. I just hope i can help someone out there like myself who was also struggling to get the newest omega driver to install.
     
  19. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #19
    Ok thanks I am gonna try to my 5k with r9 295x when I am gonna go home.
     
  20. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #20
    I tried but unfortunately no luck. Pop up the window that says I need the ati control panel and I put ok and the installation abort.
     
  21. yjchua95, Dec 9, 2014
    Last edited: Dec 9, 2014

    yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #21
    It's not nonsense, it's the truth, for it's an Apple-only card.

    And besides... who are you to judge whether it's nonsense anyway? Just look at your post count and your spelling mistakes.

    The Omega drivers are clearly not meant for Boot Camp anyway, as stated on AMD's website.

    It will work for existing architecture like Pitcairn, Tahiti...etc (that includes the M290X). However, some special variants of Pitcairn and Tahiti (like the D-series FirePro in the nMPs) may have trouble with Windows drivers.

    And for the new Tonga M295X...don't even ask.
     
  22. okami585 macrumors newbie

    Joined:
    Dec 9, 2014
    #22
    I got the new Omega Drivers to work on a Mac Pro (2013, Windows 8.1)

    I followed acuraice directions and I am up and running.
     
  23. kode54 macrumors newbie

    Joined:
    Jan 15, 2014
    #23
    I followed the same directions, and it rejects my M295X. I checked the INF file, it has a VEN_1002&PID_6921&REV_00 for M295X, but mine is VEN_1002&PID_6938&REV_00. Definitely not a match.

    Then I attempted to edit the INF file to include the correct ID, generated a new .cat file with inf2cat, then signed it with my own Authenticode certificate, but Windows rejected it. I don't feel like turning on driver test signing just to see if these drivers even work with my system.
     
  24. TerrorOFdeath, Dec 9, 2014
    Last edited: Dec 10, 2014

    TerrorOFdeath thread starter macrumors member

    TerrorOFdeath

    Joined:
    May 15, 2008
    #24
    Yeah, thats what the problem is -_- not the fact that this is YOUR "assumption". But you are probably right. Amd says so on their page, so dont question that right. Eat what others serve you and dont question that, but rather give up instead of trying. Nice... Your life must be so full.
    Besides, it wasnt my point to attack you in any way. I just said dont transfer your assumption onto others, so that they might give up on trying. In the context I said nonsense, which is for me the same as assuption just like religion ;)

    In the Inf file, there are strings for the tonga m295x. I even managed for windows to get it recognized by modding the inf file. However it wouldnt start the ccc. I think im also going to read out the string of my card and put it into the inf file and see what happens.

    Had to go back to win8.1 because somehow the win10tp had some problems. the driver would not recognize the windows version.

    @okami what kind of a gpu have you? why it worked with the 69xxseries is probably because the right string was in the inf file. you also could have simply swapped the 2 files i mentioned in the post above and it would have had worked probably too.

    The Quest continues :eek:)

    Tod
     
  25. vagos1103gr macrumors regular

    Joined:
    Jul 25, 2013
    #25
    Go on if you have any news to install the new drivers let me know.
     

Share This Page