New Apple 4K cannot connect via ethernet

Discussion in 'Apple TV and Home Theater' started by BootLoxes, Apr 15, 2019.

  1. BootLoxes macrumors newbie

    Joined:
    Apr 15, 2019
    #1
    Ok so I just got home and plugged the Apple TV up to my ethernet cable and it kept giving me a message saying it cannot connect to the internet. I thought that was weird so I switched to tethering off my phone wifi to do the initial setup.

    After finishing the setup and updating the Apple TV to the latest version, I tried again but to no luck. With the automatic settings I see I get an IP address, subnet mask, and DNS yet it does not connect. The apple tv is connected to a switch with my pc. The switch feeds straight into the modem. So my pc and apple tv are the only two physical devices.

    Things I have tried
    1. Ping the IP address from my pc (failed)
    2. Changed out ethernet cables for the apple tv (twice)
    3. Changed ports on the switch
    4. Completely disconnect the switch and have the apple tv ethernet cable go straight into the modem (fail)
    5. Manually assign an ip, gateway, and dns
    6. Restarted the Apple TV

    I do not know what else to do at this point. Wifi works fine if tethered off my phone, but thats it.
     
  2. waw74 macrumors 68040

    Joined:
    May 27, 2008
    #2
    you say it's going straight into a switch, then to your modem?

    do you have a router? or is it just a switch
    or is maybe the modem combined with the router.

    what's the first 2 numbers of your IP address on the aTV.
    If it's not 192.168 . or 10.xx then you have a switch (xx is any number)

    If you have a switch, that's your problem, as your internet provider probably only allows you 1 device
    and your devices are directly on the internet with no protection. (this is a pretty bad thing)

    to #4 in your list, when changing what's connected to the modem, you must reboot it.
    Most of the time they will only talk to what's connected when the modem powers on
    This doesn't apply to a modem/router combo.
     
  3. AManInACan macrumors member

    Joined:
    Oct 2, 2015
    #3
    I agree with waw74, that it it's likely your internet provider is only set up to provide you one IP address. That was working fine with our one PC but now that you are trying to add a second device it's not supporting it. You may be able to verify this by disconnecting the PC and rebooting the modem. This will cause it to re-provision the one address to the Apple TV - but your computer won't be able to get one.

    Here are some ideas of what you could buy that will give you good WiFi as well as 4 ports to plug in ethernet devices:
    https://www.pcmag.com/roundup/292110/the-best-wireless-routers
     
  4. BootLoxes thread starter macrumors newbie

    Joined:
    Apr 15, 2019
    #4
    Ok I switched out the switch for a router and now the issue is solved. Thanks for the advice. I learned something new
     
  5. stringent macrumors 6502

    stringent

    Joined:
    Jan 27, 2011
    Location:
    London
    #5
    LOL Welcome to the world of IT. First turn everything off then on again, then upgrade your kit!

    Glad its working now.
     
  6. BootLoxes thread starter macrumors newbie

    Joined:
    Apr 15, 2019
    #6
    Yeah. I dont need wifi where I am so I just figured I can get the switch and split the ports up. Now I know that is not the case.
     

Share This Page