New apple keyboard doesn't work properly

Discussion in 'Mac Accessories' started by ahollywoodcraig, Sep 7, 2007.

  1. ahollywoodcraig macrumors member

    Joined:
    Jan 2, 2007
    #1
    Hi, I hope someone can help me with this. I've searched, but couldn't find an answer.
    I just bought Apple's new wired keyboard and it works almost perfectly with the exception of the new dashboard and expose keys. For some reason they don't work. I installed apple's keyboard update (1.1) and restarted and still nothing.
    Am i missing or forgetting to do something? Any help is really appreciated.

    Thanks in advance,

    Craig
     
  2. MK2007 macrumors regular

    Joined:
    Aug 31, 2007
    #2
    You have to remap the keys in the Keyboard & Mouse section of System Preferences. The stupid update doesn't do it for you! I don't know what it is good for really.

    Open the System Preferences utility and click on Keyboard Shortcuts. Then scroll down to the higher numbered F keys with Dashboard. Set the keys there and they will work.
     
  3. ahollywoodcraig thread starter macrumors member

    Joined:
    Jan 2, 2007
    #3
    Thanks for the reply. I tried what you suggested, but I was under the impression that for instance when I push the Dashboard key by itself it should open. With the fix you suggested I have to push the fn key along with the f4 (dashboard) key. Am I way off in assuming this is how it is supposed to work?
    All of the other keys that perform a special function work by themselves without the need of any other keys being pressed. It's not the end of the world, but I am curious.

    Thanks,

    Craig
     
  4. styxfan macrumors member

    Joined:
    Apr 7, 2006
    #4
    I am having the exact same problem with my new keyboard on my MacBook Pro. If I want to use the dashboard or Expose´ button, I have to hold down the **** key.
     
  5. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #5
    On the keyboard tab: check Use the F1-F12 keys to control software features.
     
  6. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #6
    you're supposed to be able to hit the keys to engage dashboard/exposé without needing to map those keys. and installing the keyboard update should have been enough. in the keyboard & mouse system preference pane, the box asking to use f1, f2, etc. as standard function keys should be unchecked.
     

    Attached Files:

  7. Shotgun OS macrumors 6502a

    Joined:
    Dec 18, 2006
    Location:
    Ohio
    #7
    I've tried about everything to fix my keyboard because i have the same problem. I've heard re-installing the OS fixes it, but I'm lazy and I've learned to live without two function keys that I usually use by way of mouse buttons anyway.
     
  8. MK2007 macrumors regular

    Joined:
    Aug 31, 2007
    #8
    You don't have to live without those direct function keys.

    If F3 and F4 won't work, right click on the Dashboard. Then set up your choice of function keys.

    You will be able to get all 4 functions working with higher numbered keys, F13 thru F19. Because there are 4 functions, a good idea would be to map them using F16 thru F19 above the keypad.
     
  9. ahollywoodcraig thread starter macrumors member

    Joined:
    Jan 2, 2007
    #9
    The new keyboard update (1.2) fixed this issue for me.
    Thanks for all of the responses!

    Craig
     

Share This Page