New Apple TV won't Connect to Home Sharing

Discussion in 'Apple TV and Home Theater' started by MacbookAlum1536, Oct 5, 2010.

  1. MacbookAlum1536 macrumors regular


    Nov 21, 2008
    Hey Everyone
    I have a problem with Home sharing that didn't exist a day ago. So yesterday I set up my Apple TV and everything is working good and going to bed I had shut it off after playing around in the Computers Section and put it to sleep as well as my Home Sharing Library (MacBook in signature-All updates current). Then Today after school I go to listen to some music and the computer isn't showing so naturally I go through the troubleshooting (Shut down computer, unplug aTV, Toggle home sharing, and the network) but none of it worked so I'm at a bit of a loss after it worked yesterday.
    Thanks for any help.
    P.S. I did search this on Mroogle but couldn't find anything useful.
  2. mykoljay macrumors member

    Feb 1, 2008
    Do you have the most rent update to itunes? I needed to update it in order for the home sharing to work,
  3. DJinTX macrumors 6502

    Sep 15, 2010
    If homesharing has never worked, make sure iTunes is up to date and you should be fine. If it has worked and then stopped, have you tried re-entering both your network settings and iTunes account login? I have heard some users say that they are seeing a pattern of having to re-enter settings.

    If worse comes to worse you apparently can either use the reset function in the settings menu, or you can connect it to your mac with a USB/micro usb cable and restore it to factory settings. I'm not sure if the reset and the restore do all of the same things, but they will both require you to re-enter all of your settings afterward. It might be worth a try. Beyond this it might be time to call Apple.
  4. theman510 macrumors 6502a

    May 13, 2009
    New Jersey
    I couldn't get mine to work at all over wifi, yesterday I plugged in an ethernet cable straight from my router and has been working flawlessly, even faster than I anticipated. Did you try this?
  5. illitrate23 macrumors 6502a


    Jun 11, 2004
    i had a similar issue which was resolved by quitting and re-opening iTunes on my iMac - the :apple:TV picked it up right away without any need to do anything to it
  6. cflorio macrumors member

    Jul 3, 2007
    I'm having a similar problem with the wireless networking. See here:

Share This Page