new battery installed. now only charges upside down

Discussion in 'MacBook Pro' started by applefanatiz, Feb 7, 2015.

  1. applefanatiz macrumors newbie

    Joined:
    Feb 7, 2015
    #1
    So I have a mid-2009 macbook pro. The battery just died so bought an used Apple battery off eBay. It charged ok when I installed it first time. Now it won't charge anymore. However it charges when I put the macbook pro upside down. Donno why, any suggestions?

    P.S: I did the usual troubleshooting (shutdown>disconnect battery>connect magsafe> connect battery.....) didn't work. I am yet to put my old dead battery and see it it is actually the new battery that is faulty.

    many thanks
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    If its brand new, take it back or contact the seller. That does not sound right and something is wrong with the battery.
     
  3. Zxxv macrumors 68040

    Joined:
    Nov 13, 2011
    Location:
    UK
    #3
    I think someones sold you an Australian battery. I'd take it back explain calmly its meant for Australian products and ask for another one.
     
  4. applefanatiz thread starter macrumors newbie

    Joined:
    Feb 7, 2015
    #4
    Surprisingly, I reinstalled my old battery, but the problem remains. It wont charge for a while and then suddenly starts charging again and then not again. Sometimes the orange light on magsafe keeps blinking as if it is struggling to charge. Donno what to do now. Any help would be appreciated.

    thanks
     
  5. SkimMilk168 macrumors regular

    Joined:
    Mar 19, 2014
    Location:
    Singapore
    #5
    Not sure how a 2009 MBP is like but I'd suggest to look at the contact points. How does the battery provide power to your unit? It sounds like the contacts are not touching properly and they touch when u flip your mbp upside down.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Are the contacts on the magsafe connector clean, and undamaged?
    Be sure to inspect both the adapter side, and the built-in connector on the MBPro.
    Try a different power adapter, if possible.

    If you plug in the power adapter, then press the battery test button on the side, do the lights appear normal?
    Try an SMC reset - http://support.apple.com/en-us/HT201295
     
  7. duffyanneal macrumors 6502a

    duffyanneal

    Joined:
    Feb 5, 2008
    Location:
    ATL
    #7
    Sounds like the battery connection on the mobo may be intermittant since it is now happening on both batteries. I would start there. There may be a broken solder joint or flaky pin on the connector.
     

Share This Page