NEW Draco EVO case! Resolved issues of the old Draco IV case?

Discussion in 'iPhone Accessories' started by SCARY GAY DAD, Jun 25, 2012.

  1. SCARY GAY DAD macrumors 6502

    SCARY GAY DAD

    Joined:
    Dec 3, 2011
    Location:
    DISNEYLAND
    #1
    Does anyone have this? I lost around 10 dBm with the Draco IV. Wondering if the new Draco EVO has fixed the reception loss issue.

    Informational page

    Product page
     
  2. Munkypoo7 macrumors 6502

    Munkypoo7

    Joined:
    Oct 24, 2011
    Location:
    Miami, FL
    #2
    Just as the Vapor Comp and other hybrid cases, this should solve all of the if not 99.9% of signal issues, impressive indeed :)
     
  3. eg2007 macrumors 6502

    Joined:
    May 23, 2007
    #3
    I saw the EVO on Draco's the other day too. They look really nice. Looks like they did what El3ctron did with their hybrid case.

    Still use my Draco Crystal every now an then, but my go to case is still the SGP Linear EX. That said, someone else has to be a guinea pig this time around and get one of these Draco EVO's. I'd love to hear if they solved the issue!
     
  4. Gonz19 macrumors regular

    Joined:
    Aug 2, 2010
    #4
    Made the plunge. Will review when it arrives.
     
  5. SCARY GAY DAD thread starter macrumors 6502

    SCARY GAY DAD

    Joined:
    Dec 3, 2011
    Location:
    DISNEYLAND
    #5
    Awesome! What color did you get? I'm especially interested if the texture of the black plastic on the all black version is shiny or matches the matte black of the rest of the bumper.

    Please post photos as well!
     
  6. Gonz19 macrumors regular

    Joined:
    Aug 2, 2010
    #6
    Went with the white/silver combo since I have a white iPhone. Wil post pics when it arrives next week.
     
  7. Gonz19 macrumors regular

    Joined:
    Aug 2, 2010
    #7
    Got it today and am quite impressed. No signal loss whatsoever. Alignment is about off when the pieces screw together. Gonna see if it can be adjusted. Will post pics soon.
     
  8. SCARY GAY DAD thread starter macrumors 6502

    SCARY GAY DAD

    Joined:
    Dec 3, 2011
    Location:
    DISNEYLAND
    #8
    Did you perform a field test to validate that no signal was indeed lost?

    Did/Do you have the Draco IV? How many dBm did you lose with that? For me, I consistently lost 10 dBm (which does NOT have a linear relationship with signal bars).
     
  9. Gonz19 macrumors regular

    Joined:
    Aug 2, 2010
    #9
    Let me take that back. There was a bit of loss, but my signal strength is always pretty high. As far as actual signal, with the case off, it was -79 and with it on -82 to -85. Wifi works fine, but it does take a bit for it to lock on GPS and is sometimes a bit off. Case didn't fit flush when put together, but with a bit of adjusting I was able to get it to fit pretty well. Still haven't had time to take pics but will try tomorrow. After hearing all the negative feedback about signal loss, I never got the original Draco so I can't really compare the 2.
     
  10. radicalDESIGNZ macrumors member

    Joined:
    Jan 29, 2010
    #10
    thanks for the feedback, it made my decision to not buy it easier.
     
  11. pdxa4 macrumors 6502

    Joined:
    Aug 4, 2008
    #11
    Just after reading the review on gadgetmac, seems like the reception issue is now resolved, but I am curious on the GPS signal.
     

Share This Page