New drive won't boot internally

Discussion in 'MacBook Pro' started by sdlwdr, Mar 25, 2015.

  1. sdlwdr, Mar 25, 2015
    Last edited: Mar 25, 2015

    sdlwdr macrumors newbie

    Joined:
    Mar 25, 2015
    #1
    Hi All,

    So I purchased a new 2TB drive (Samsung model #ST2000LM003) for my 13" MacBook Pro. No issues with the old one, just getting close to capacity. I connected it with a SATA/USB adapter, formatted it, and copied everything over with Carbon Copy Cloner. The transfer completed successfully, and the recovery partition was cloned successfully as well. I then verified the disk (no problems) and permissions (a few problems found and repaired successfully). The new drive boots fine over the SATA/USB adapter, but behaves very strangely when installed.

    If I try booting normally, I get the folder with flashing question mark logo. Resetting the PRAM doesn't help, and it's not an issue with the SATA cable or logic board since the old drive still boots fine internally. If I hold alt/option while booting, the only choice provided is Internet Recovery. Even if another bootable USB drive is connected (including the old hard drive), Internet Recovery is the only option. I looked in Disk Utility through Internet Recovery -- the new drive (installed internally) does show up there, but its partition scheme is listed as Master Boot Record which is wrong (it's definitely GUID). Rather than the 2TB partition I created, it shows a single 250GB partition with a generic name. The verification buttons for the disk and the partition are all greyed out.

    At this point I'm completely stumped, any help would be greatly appreciated.

    Thank You

    --
    Mid-2012 13.3" MacBook Pro (Model A1278)
    OS: Yosemite 10.10.2
    RAM: 8GB 1600MHz DDR3
    Processor: 2.9 GHz Intel Core i7
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Put your new drive internally and the original drive in the USB adapter.

    Boot off your old drive in the USB adapter.

    Can you format the internal now?
    Can you clone your old drive to your new one?
    Can you then boot off the new drive?
     
  3. sdlwdr thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #3
    When the new drive is installed internally, the old one isn't bootable over USB. The only option available is Internet Recovery.
     
  4. sdlwdr thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #4
    RESOLVED

    Turns out this was an issue with my USB/SATA adapter misreading and miswriting the partition scheme of drives. It reads GUID as MBR and writes MBR instead of GUID. I tried cloning through a $2 SATA/MiniUSB enclosure instead and it worked perfectly.

    The original adapter was a StarTech USB2.0 to SATA IDE Adapter:
    http://www.amazon.com/StarTech-USB-SATA-Adapter-USB2SATAIDE/dp/B000VS4HDM/
     

Share This Page