New Early 2009 Mac Mini not sleeping

Discussion in 'Mac mini' started by jmpage2, Mar 22, 2009.

  1. jmpage2 macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #1
    Does anyone have any ideas on why this might be occurring? I've only installed a few applications on the Mini and no hacks.

    The monitor will shut off but the Mini won't go to sleep on its own.
     
  2. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #2
    How do you know it's not sleeping? Does the power light not fade in and out?
     
  3. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #3
    I know it's not sleeping because the power light does not fade in and out, and more notably the mouse that's connected to it doesn't have it's lighting shut off.

    When I force the Mini to sleep the mouse light goes off and the power light fades in and out.
     
  4. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #4
    I'm a little confused. You say when you force the Mini to sleep, it does go to sleep (power light fades in and out). I'm assuming you select the sleep option under the Apple dropdown. If so, isn't it functioning properly then? How else would it go to sleep, unless you mean by unattended timeout.
     
  5. Nukemkb macrumors 6502a

    Nukemkb

    Joined:
    Mar 12, 2006
    Location:
    Columbia, SC
  6. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #6
    That's right. If Energy Saver timeout is set too high, you'll never see the Mini go to sleep from timeout.
     
  7. Nukemkb macrumors 6502a

    Nukemkb

    Joined:
    Mar 12, 2006
    Location:
    Columbia, SC
    #7
    and the answer is..............:confused:
     
  8. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #8
    I'm referring to it not going to sleep on its own when the energy saver timeout takes place (it's currently set at the default value of 10 minutes for display timeout and computer sleep).

    When I first got the Mini a few days ago it would go to sleep if I left it unattended for more than 10 minutes.

    Now, it only goes to sleep if I force it, otherwise the display shuts off but the computer is never going to sleep.

    The only applications I've loaded on the Mini are Turbotax and Firefox.
     
  9. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #9
    Go ahead, you found this one.:eek:
     
  10. Nukemkb macrumors 6502a

    Nukemkb

    Joined:
    Mar 12, 2006
    Location:
    Columbia, SC
    #10
    What's running in the background?
     
  11. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #11
    Test the Energy Saver by setting it to the lowest timeout - 1 min., and see if it works. The other possibility is that any disturbance to the keyboard or mouse will reset the timeout clock, and this may be happening without your realizing.
     
  12. Nukemkb macrumors 6502a

    Nukemkb

    Joined:
    Mar 12, 2006
    Location:
    Columbia, SC
    #12
    very good.
     
  13. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #13
    Still not working with it set to minimum values.
     
  14. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #14
    Ah dunno.
     
  15. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #15
    It does work after a reboot, so apparently some application that gets run after restart, or website visit, etc, is keeping it awake.
     
  16. Aegelward macrumors 6502a

    Joined:
    Jul 31, 2005
    Location:
    UK
    #16
    Do you have a usb hdd plugged in, for the wierdist reason mine wont' sleep when it has a usb drive in it
     
  17. txnoob macrumors 6502

    Joined:
    Mar 12, 2009
    #17
    Mine behaves similar to the way yours does. But I know it's at least dozing because light on my ext. HDD is out, the mouse is out and won't respond until I click or make a keystroke. When I do, I hear the SD spin up and magically the screen appears.

    What I would like to note, is that the light does not fade in and out on this mac when it goes into this "power save" mode by itself. It only does that when I actually put it to sleep from the apple menu.
     
  18. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #18
    I have a keyboard, mouse, iphone dock and DVI display plugged in. No external discs. I did upgrade RAM to 4gb before ever powering it up when I first got it but I don't think that could cause this.

    So far it will sleep after last reboot with firefox, mail and iPhoto running.
     
  19. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #19
    I never tested Energy Saver timeout. Well, mine seems to behave the same way. But I noticed the defaults in Energy Saver could be causing this. Computer sleep is set higher than display sleep. So altho it may appear that the computer is supposed to be sleeping, it's just the display that is. I haven't done this yet, but a test would be to set computer sleep to one minute and see.
     
  20. blehargh macrumors newbie

    Joined:
    Mar 23, 2009
    #20
    From Apple.

    Here's a support page for why it could not be going to sleep...

    http://support.apple.com/kb/HT1776

    Funny. I just noticed that mine doesn't do to sleep either on it's own. So I'm going to have to figure out why also. :) GL.
    -don
     
  21. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #21
    Well, in my case it seems to have something to do with iTunes and/or network share access.

    It was sleeping fine until I opened iTunes, played some music from a network share and then closed iTunes.

    Now it's back to not sleeping.
     
  22. inVaUSA macrumors newbie

    Joined:
    Mar 4, 2009
    Location:
    Virginia
    #22
    I am having the same issue, but I think iChat is keeping my system awake. It is the only application that I can see running on my system.

    I also have my mini attached to a Dell LCD TV, so that might have something to do with it. I have noticed some weird things as a result of using a TV for a monitor.
     
  23. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #23
    All I know is if my Mac is not going to sleep every time I have used iTunes I'm going to get pretty irritated.
     
  24. Macman756 macrumors 6502a

    Macman756

    Joined:
    Sep 24, 2008
    Location:
    Atlanta, GA
  25. jmpage2 thread starter macrumors 68030

    jmpage2

    Joined:
    Sep 14, 2007
    #25
    It has nothing to do with the energy saving preferences, it is being caused by something being done with the computer, as that's the only explanation for it working for a while, and then no longer working until a reboot is done on it.
     

Share This Page