New error code when formatting "unable to write to the last block of the device"

Discussion in 'Mac OS X Lion (10.7)' started by MikeonTV, Aug 11, 2011.

  1. MikeonTV macrumors regular

    Aug 9, 2007
    I have a 1TB WD Elements external drive that was being used on a Windows 7 machine. One day the disk become unrecognised on the computer.

    I've plugged it into my MBP (10.7) and was able to recognise the disk in the disk utility.

    I tried to erase and partition it with all possible settings but I always get the same error

    "unable to write to the last block of the device"

    Looking on google this appears to be a new error message from Lion.

    Can anyone recommend a way to bypass the error? Terminal?

    Is there another OSX disk utility app that may not have the same issues?
  2. mdnz macrumors regular

    Apr 14, 2010
    The Netherlands
    This sounds like a failing harddrive. Dowload Smart Utililty and check the health of the hard drive. If there are any errors the hard drive is failing and will have to be replaced.
  3. MikeonTV thread starter macrumors regular

    Aug 9, 2007

    Thanks. I tried that and the drive never appeared on Smart Utility. Any other ideas?
  4. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    Disk Utility can check the SMART status of the drive.
    Just open Disk Utility and check the status of the drive at the bottom of the window.
    I use SmartReporter as well.

    Attached Files:

  5. reputationZed macrumors 65816

    Mar 9, 2011
    34°55′42″N 80°44′41″W (34.
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    I'm getting the same error with my Drobo. I upgraded to Lion without updating the Drobo's software, which I learned after the fact can lead to problems. I'm still working with Drobo support to resolve the problem.

    I wouldn't be overly concerned with what SMART tells you, the accuracy of it's results can be questionable.
  6. MikeonTV thread starter macrumors regular

    Aug 9, 2007
    Hi there. Thanks for the reply. This application doesn't recognize the drive either. The only app which does is the stock disk utility app.

    I'm beginning to think I'll have to start making the proper funeral arrangements.
  7. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    Hmm, that could be a problem. If you want to invest money in it try a data recovery/tools program. If not fall back to your backup.
  8. bgmac macrumors newbie

    Aug 17, 2011
    Possible WD link

    I experienced similar problem as first post in this thread. I purchased a 3GB WD External HD (My Book Essential) and ended up harvesting the HD to place in my Time Capsule (a 1TB model). The swap out went fine; the Time Capsule was able to format and use the new 3TB drive (via Airport Utility) but the old 1 TB HD from the Time Capsule was unable to be recognized when I connected it using the WD SATA > USB hardware from the WD ext HD. I got the "last block" error with Disk Utility. No better with DiskWarrior or Drive Genius. I fired up the WD Smartware which recognized the HD but failed to format. I even took the now Time Capsule formatted 3TB HD and put it back in the WD enclosure and it too produced the same error when trying to format.
    To get to the punchline both of the bare HDs were fine and formatted just fine with a different enclosure (non WD). Once I SECURELY erased the 1 TB HD, it worked fine with the WD hardware attached. I believe that WD may have a hardware linked security feature that locks out the HD from being formatted - bricks it in a sense if it "discovers" that the HD has been tampered with. With a securely erased HD, presumably it was wiped clean and I was able to format the drive using WD Smartware and since then has worked well with Disk Utility and torture tested with Drive Genius.

    Try SECURELY erasing your bare troubled HD using a non WD interface. Worked for me.
  9. nekkyj macrumors newbie

    Nov 27, 2011
    bgmac is right - DEFINITELY some proprietary WD hardware interference. I used a cheapie SATA to USB convertor cables to access the drive and follow the instructions below... thank you!

  10. lapeno macrumors 6502

    Jul 26, 2010

    I Just bought a 2tb my passport and am getting the same message as in the first post.

    Could someone please tell me how to securely erase this disk.


Share This Page