New hard drive..is loose??

kinkster

macrumors 6502a
Original poster
Sep 15, 2008
534
0
On my 13 inch MBP, I just installed a new WD scorpio blue hard drive. I'm pretty sure I did everything right, but it wiggles around. What's wrong?
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,967
0
Did you move the 4 screws from the original hard drive onto the new one?
 
Comment

kinkster

macrumors 6502a
Original poster
Sep 15, 2008
534
0
4 screws from the original? I only removed 2 to remove the original HD, the two black ones over the plastic "arm" that goes over the edge of the HD.
 
Comment

apple2c

macrumors newbie
Dec 7, 2009
2
0
I've got the exact same problem. Not sure what to do about it. What's the latest K?
 
Comment

erratikmind

macrumors 6502a
Apr 2, 2009
771
1
S.F./Las Vegas
I've got the exact same problem. Not sure what to do about it. What's the latest K?
Take a look at the hard drive, which you removed. It should have 2 torx 6 screws screwed into either side (for a total of 4) of the hard drive. These 4 screws need to be removed and replaced on to the new hard drive prior to remounting.
 
Comment

Wotan31

macrumors 6502
Jun 5, 2008
491
0
Take a look at the hard drive, which you removed. It should have 2 torx 6 screws screwed into either side (for a total of 4) of the hard drive. These 4 screws need to be removed and replaced on to the new hard drive prior to remounting.
x2, there are *four* torx screws that need to be transferred from the old drive to the new.
 
Comment

apple2c

macrumors newbie
Dec 7, 2009
2
0
thanks cheeto, erat, wotan et al.

worked.

somehow I missed that step...

I really appreciate it.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.