New Hard Drive Restore Problems

Discussion in 'MacBook' started by Hollowmoor, Aug 12, 2010.

  1. Hollowmoor macrumors newbie

    Joined:
    Aug 12, 2010
    #1
    Hello all,

    I've just fitted a new 500Gb Samsung hard drive into my Oct 2008 unibody Macbook, formatted the hard drive and then restored snow leopard from a recent time machine backup.

    Everything went fine except that there now seems to be a problem with the trackpad. I've lost the right click and 2, 3 and 4 finger commands completely. I tried unticking and then re-ticking these functions in system preferences but it hasn't made any difference.

    Does anyone know why this has happened and how I can fix it?

    Cheers,
    Don.
     
  2. Hollowmoor thread starter macrumors newbie

    Joined:
    Aug 12, 2010
    #2
    Update:

    I've tried a new approach - erased hard drive, did a clean install of Snow Leopard, applied all updates and used migration assistant to load apps and files from the last time machine backup.

    The trackpad is fuctioning OK now but can anyone suggest why it lost so much functionality after the Time Machine restore?
     
  3. AlphaDogg macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #3
    I have no idea. It could be that you were trying to restore from a newer version of OS X (like 10.6.4) and you only had 10.6.3. That is all I can come up with.
     

Share This Page