New headset

Discussion in 'MacBook Pro' started by pim16aap2, Oct 8, 2013.

  1. pim16aap2 macrumors newbie

    Joined:
    Oct 29, 2011
    #1
    Hello,

    I just bought a Tritton Pro+, which can be connected to my MBP (13" 5,5 mid-2009) via USB + 3.5mm jack.

    As soon as I plug it into the USB port, it start making lots of awful noises, which can be best compared to massive, blocky pieces of concrete rolling down a slope 2 cm behind my back. When I plug the audio cable in, the sound I get from it is very good, but it's still raining concrete on the background, unless I turn my volume way up.

    I have tried unplugging everything / moving my MBP around / changing volume, and the closest I got (unplugged everything + walked away with it), was still horrible and only slightly better.

    When I plugged the USB cable in my phone's power -> USB adapter and the audio cable into my MPB's, the sound was clear and perfect... but... That way I cannot connect my mic, which is something I really need to use.

    It also works fine when I plug it all into my iMac, but I really need it to work here.

    Would there be any way I could possibly fix this?

    Regards,
    Pim
     
  2. pim16aap2 thread starter macrumors newbie

    Joined:
    Oct 29, 2011
    #2
    Would adding an external sound card work?

    I wouldn't want to spend money on it if I would end up with the very same problem.

    Or would there maybe be some kind of bluetooth device I could plug the USB cable into which then connects to my MBP?
     

Share This Page