New home network - trouble with wireless printer

Discussion in 'Mac Accessories' started by rvdavis, Jun 1, 2010.

  1. rvdavis macrumors newbie

    Joined:
    Jun 1, 2010
    #1
    I recently changed from a 2Wire home wireless router to a Dlink and am having trouble printing to my wireless printer. I set up the printer with the new WEP key. It works sometimes, but not all of the time. Any suggestions?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    As almost always, more information is needed.

    What exact DLink router, what exact printer model and what Mac OS X version do you use?

    Also what are the network settings your printer, your router and your Mac use to talk to each other, besides the obvious WEP protection?
     
  3. walshman macrumors newbie

    Joined:
    Mar 5, 2009
    #3
    I also had the same issue with a d-link and lnyxs router. Lost connections at various times to printer, internet. Tried everything and the only thing that solved it was buying airport extreme. have not had one issue since then
     
  4. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK

Share This Page