New HTML signature in iOS 6... NOT WORKING!?

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
I have tried to get the new HTML Signature in iOS 6 to work with my iPhone and iPad, but with mixed success, and are now desperately looking for help to get this to work properly!!

Firstly I tried to copy an html mail signature into the signature field in settings on my iPhone 4S, it somehow worked out, and I can now send emails with my normal Outlook signature! ABSOLUTELY BRILLIANT! :) But when I now try to access the signature field in settings on my iPhone, the settings app crashes!? :-/ And when I now try to get this to work, copying our outlook HTML signature onto the rest of the company's iPhones, with the same procedure of copy and paste, nothing is working no matter what I try!? And on top of this, when I now try to do the exact same with my iPad2, meaning copy and paste my normal Outlook Signature, its NOT working either!??

Anyone out there who can tell me why this new function in iOS 6 is NOT working!??

Any help would be greatly appreciated!
 

robdam1001

macrumors 6502a
Sep 23, 2008
998
2
It's strange; I copied an HTML siggy from an email created on my pc to the iphone 5/iOS6. The new HTML siggy works....for awhile...and then I just start seeing a white box around where the jpg pic is supposed to be. I don't get it.


 

formulatwo

macrumors member
Sep 19, 2012
59
0
I don't use a HTML signature but could it be that the phone cannot retrieve that graphic (assuming the graphic is calling a web URL)? Or it is not retrieving the graphic in the new message screen. Have you tired sending a test email to see if it comes through OK on the receivers side?
 

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
@formulatwo

Our company signatures are not calling anything! They have just been set up in Outlook, and I have now been trying to sent them to the phones and just copy-paste them into the signature settings! See attached screen dumps of the first one I for some reason succeeded with and another one that is doing what every other iPhone and my iPad 2, I have been trying this trick on, is doing... messing up all advanced font settings!!

Hmmmm... wasn't able to figure out how to attach several photos from my iPhone here... So here is the one that fails as every other, and in a new post will be the one that succeeded and is how it is meant to be!...
 

Attachments

asggold

macrumors member
Sep 21, 2012
33
8
Same thing happening to me. I did notice that if I scroll down in the setting VERY slowly I am able to get into the signature without it crashing.

Would love to know if/when someone finds a fix. This is one of the things I have really been looking for in iOS6.
 

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
Same thing happening to me. I did notice that if I scroll down in the setting VERY slowly I am able to get into the signature without it crashing.

Would love to know if/when someone finds a fix. This is one of the things I have really been looking for in iOS6.
Hmmmm... you're right!!?? I can actually access the mailsignature without the settings app crashing, by scrolling down REeeeALLY slow! Anytime I speed up, the App crashes!!...

And I agree... this HTML signature function was one of the things I have been looking forward to the most in iOS 6! The inconsistency of having one mail signature when working in Outlook on my work PC and a different mail signature for when I am on my iPhone, has really been bothering me!!
 

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
I'll try to flip this one around...

Anyone for whom this HTML signature in iOS 6 is actually working!!???
 

robdam1001

macrumors 6502a
Sep 23, 2008
998
2
I'll try to flip this one around...

Anyone for whom this HTML signature in iOS 6 is actually working!!???
It *seems* to be working for me now; What I did was go to https://www.coolgeex.com/ and created a free custom HTML Signature there. I emailed it to my iphone 5 and copied into the appropriate Signature block. 3 Days so far and it's been rock solid.

 

asggold

macrumors member
Sep 21, 2012
33
8
@robdam1001...Thanks. That does seem to work and the settings don't crash either. Seems strange it will not copy from any HTML signature but the settings must be looking somewhere to verify that keeps crashing when you do a cut and paste. The nice thing is that once you build the signature and have it sent I was able to change around within the signature on the iPhone to exactly how I wanted it to look and the HTML still worked.
 

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
It *seems* to be working for me now; What I did was go to https://www.coolgeex.com/ and created a free custom HTML Signature there. I emailed it to my iphone 5 and copied into the appropriate Signature block. 3 Days so far and it's been rock solid.
Checked it out! This "workaround " as I would call it, is not going to work for us... if you see our mailsignature, that I added in an earlier post, you'll notice settings, that are different than what is possible with Coolgeex!

Still cannot undestand why copy-pasting a simple HTML signature... No biggy, No heavy duty coding, no nothing... is not working on any of our iPhones!! Well not exactly correct, since it is working on my own... a little buggy as stated, but it IS actually working!??

I am beginning to believe that their promise of a HTML signature i limited to the "right" HTML signature! EXTREMELY disapointing if thats correct!! :mad:
 

robdam1001

macrumors 6502a
Sep 23, 2008
998
2
Checked it out! This "workaround " as I would call it, is not going to work for us... if you see our mailsignature, that I added in an earlier post, you'll notice settings, that are different than what is possible with Coolgeex!

Still cannot undestand why copy-pasting a simple HTML signature... No biggy, No heavy duty coding, no nothing... is not working on any of our iPhones!! Well not exactly correct, since it is working on my own... a little buggy as stated, but it IS actually working!??

I am beginning to believe that their promise of a HTML signature i limited to the "right" HTML signature! EXTREMELY disapointing if thats correct!! :mad:
What "settings" exactly are you referring to?
 

robdam1001

macrumors 6502a
Sep 23, 2008
998
2
Indentation and Unique character!

I just wanna copy and paste our standard HTML signature for heavens sake!! :( How hard can it be!??
can you convert the part that won't process into a jpg, (Indentation and Unique character), and then insert it into the signature?
 

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
can you convert the part that won't process into a jpg, (Indentation and Unique character), and then insert it into the signature?
First of all, I really appreciate your effort here!! REALLY!! :)

My big problem here is I really dont wanna "work around", jumping through hoops to get this simple thing to work! I just wanna be able to copy and paste our regular HTML signature into the iPhone and the iPads in our company, because it would mean alot for our presence towards out customers, that the signature is the same, anyway they recieve a mail from us... in plain text!! And I KNOW it can work... my iPhone 4S with iOS 6 IS working this way... I just CANNOT for the life of me, reproduce this on all the other iPhones and iPads in our company!!???

I just cannot believe that when things work on one iPhone (a few bumpy problems though, but it IS working) I just cannot make it work on ANY other iPhone!??...

Just wanna repeat myself here... are there anyone out there, for whom copy and pasting a simple HTML signature into the iOS 6 settings is just a breeze!??

Anyone!???
 

thewhitetower

macrumors regular
Jun 25, 2011
115
39
my html email sig is pretty simple but my name has a color to it...

unfortunately when I copy/paste it into the relevant field in setting, the color does not replicate and comes out as black...anyway to fix this?
 

arkoh

macrumors member
Original poster
May 24, 2009
42
15
Copenhagen
my html email sig is pretty simple but my name has a color to it...

unfortunately when I copy/paste it into the relevant field in setting, the color does not replicate and comes out as black...anyway to fix this?
Same problem for me!
The colors are changed to black and the font types are changed a different one!... and other things!

So I am NOT the only one with this problem I see!??
 

thewhitetower

macrumors regular
Jun 25, 2011
115
39
Same problem for me!
The colors are changed to black and the font types are changed a different one!... and other things!

So I am NOT the only one with this problem I see!??
strange thing is that I was jailbroken on iOS5 and used signify to create a html email tag...then when I restored from backup to iOS6 it transferred across!!!...even though I wasn't jb'ed....the email tag was obviously backed up in the relevant mail file somehow...

but then, whilst on iOS6, I reset my settings to solve the battery drain issue and kaboom...the sig was gone!!:mad:
 

r2shyyou

macrumors 68000
Oct 3, 2010
1,757
4
Paris, France
In my experience with this, HTML text formatting is retained if the signature is copied either from an email you're composing (e.g. sending yourself an email containing your signature and then hitting either Reply or Forward to open up a Compose window) or from an email you're just viewing (i.e. copying the signature before hitting Reply or Forward)...but I can't remember which one.

Whichever way I first did it resulted in the color of the text reverting to black but the 2nd way I did it has worked.

Oh and, in addition to dark blue, italicized text, my company requires us to have an image as part of our email signature (the whole thing doesn't actually look as bad as it might sound) which, as others have mentioned, seems to disappear after a short while.

EDIT: just tested this and formatting is retained when the signature is copied from within a Compose window.
 
Last edited:

thewhitetower

macrumors regular
Jun 25, 2011
115
39
In my experience with this, HTML text formatting is retained if the signature is copied either from an email you're composing (e.g. sending yourself an email containing your signature and then hitting either Reply or Forward to open up a Compose window) or from an email you're just viewing (i.e. copying the signature before hitting Reply or Forward)...but I can't remember which one.

Whichever way I first did it resulted in the color of the text reverting to black but the 2nd way I did it has worked.

Oh and, in addition to dark blue, italicized text, my company requires us to have an image as part of our email signature (the whole thing doesn't actually look as bad as it might sound) which, as others have mentioned, seems to disappear after a short while.

EDIT: just tested this and formatting is retained when the signature is copied from within a Compose window.
You absolute champion! Copying the sig after hitting fwd or reply transfers across:)...only thing is though, that the 'blue line' (which comes up as a result of hitting reply or fwd) running along the left of the text block transfers as well!! Any ideas on how to get rid of it?.
 

r2shyyou

macrumors 68000
Oct 3, 2010
1,757
4
Paris, France
You absolute champion! Copying the sig after hitting fwd or reply transfers across:)...only thing is though, that the 'blue line' (which comes up as a result of hitting reply or fwd) running along the left of the text block transfers as well!! Any ideas on how to get rid of it?.
Great, glad it (mostly) worked. As for the blue line, I believe that's a result of quote indentation. You can toggle this on or off in Settings:

Settings > Mail, Contacts, Calendars > Increase Quote Level > On/Off

If you turn this off, the blue line should no longer appear when replying or forwarding.
 

Attachments

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.