New iBook USB ports faulty?

kleinerp

macrumors newbie
Original poster
Jul 16, 2005
13
0
I have just received my new 12" 1.33GHz iBook and wondered if there was anyone successfully using a SmartDisk Firelite USB powered HD with it?

When I plug it into either of the two USB ports (which are supposed to be USB 2.0) the drive does not power up and just clicks. The manual says that if a clicking sound is heard then not enough power is being supplied. How can this be - the ports are supposed to be USB 2.0!!

I have tried the drive on a Mac Mini at work running Tiger and it is recognised fine. If it works fine through the USB 2.0 ports on the Mini then it should work through the USB 2.0 ports on the iBook shouldn't it?

I've also tested the drive on the USB 2.0 ports on my work Windows machine and it runs fine. So I can safely say that the external hard drive is not the problem.

Any ideas? Can anyone help?
 

pdpfilms

macrumors 68020
Jun 29, 2004
2,382
0
Vermontana
My only guess would be that the drive is attempting to draw more power (power, not data) from the USB connection than the iBook can deliver. Maybe the USB bus on the iBook was not allocated much power in order to keep running life on a single charge optimal...

Have you tried with the iBook plugged in?

Honestly, i'm just as confused as you, but maybe this helps.
 
Comment

kleinerp

macrumors newbie
Original poster
Jul 16, 2005
13
0
I've tried resetting PRAM, NVRAM, PMU. The iBook is plugged into the mains and still the hard drive does not power up!!

Would be good to hear if there is anyone who has a Firelite drive working with their iBook.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.