New iMac 27" i7 , surfing very slow.

spmiz12

macrumors regular
Original poster
Nov 17, 2009
179
0
Hello. I am new to the mac world and this past Sunday, I purchased the new 27" i7 model. I am running a cable internet feed, running at . On Sunday and Monday, I was noticing no problem with surfing speeds at all; however this evening surfing really slowed down. I have both Safari and Firefox, yet both are slow; safari seems to take along time to load. Like I said I am new to a mac; so I am wondering if anyone can lend me a hand or any ideas????

Thanks
 

OldCorpse

macrumors 65816
Dec 7, 2005
1,478
90
compost heap
Hello. I am new to the mac world and this past Sunday, I purchased the new 27" i7 model. I am running a cable internet feed, running at . On Sunday and Monday, I was noticing no problem with surfing speeds at all; however this evening surfing really slowed down. I have both Safari and Firefox, yet both are slow; safari seems to take along time to load. Like I said I am new to a mac; so I am wondering if anyone can lend me a hand or any ideas????

Thanks
Surfing is slow... what exactly do you mean? Pages don't load? Graphics load slowly? Or are you slow to connect to sites? Have you eliminated problems that may be centered around your internet connection, ISP or router? You must isolate your problem area before we can diagnose.
 
Comment

spmiz12

macrumors regular
Original poster
Nov 17, 2009
179
0
Sorry..... I have tested internet speed via provider tests and I am running extremely high speed range. What is happening is that my brower windows do open up, but it takes several seconds for a page to load up; whether or not it is very graphical. Just seems strange because Sunday and Monday, this thing was blazing fast even with multiple windows open; but now it is very slow with one brower window open. And my docked apps seem to be running very well....
 
Comment

nicroma

macrumors 6502a
Jun 20, 2009
504
30
Midwest, USA
Have you tried rebooting? I've had a few quirks with my i7 that shouldn't require a reboot but it has fixed them all. I've actually had to reboot it more than my Windows machine.
 
Comment

fruitpunch.ben

macrumors 6502a
Sep 16, 2008
587
156
Surrey, BC
Sorry..... I have tested internet speed via provider tests and I am running extremely high speed range. What is happening is that my brower windows do open up, but it takes several seconds for a page to load up; whether or not it is very graphical. Just seems strange because Sunday and Monday, this thing was blazing fast even with multiple windows open; but now it is very slow with one brower window open. And my docked apps seem to be running very well....
have you updated all the software? 10.6.2 seemed to have fixed all slowdown problems.
Others who have experienced slowdown problems with the new iMacs found that they were fixed by doing a fresh install of SL using the restore discs that came with the machine. I'd try that otherwise.
 
Comment

spmiz12

macrumors regular
Original poster
Nov 17, 2009
179
0
I did a software update and I am running 10.6.2; it only added a update to safari.....

I have noticed that the slow down to the browers is really bad whenever I am downloading anything. I was really impressed with the speed the last two days and frankly VERY impressed but now I wonder what is up; I hope I didn't clutter something up or messed something up.

I also only have Safrai ( single window ) , firefox ( 2 windows ) and finder running......

Thanks for any help.

I am not trying to as a doubt question, so bare with me. But what is reloading the SL?? Is that the complete reload, and will I lose all my apps??

Thanks again...
 
Comment

ntrigue

macrumors 68040
Jul 30, 2007
3,805
1
Sounds like a DNS issue. Google OpenDNS and put those settings in.
 
Comment

dougb256

macrumors member
Nov 16, 2009
76
0
Put what settings in where? I too am experiencing what the OP is talking about - my connection speed right now is 19360 kbps, but if I load a new page it either takes forever or I have to hit refresh.
 
Comment

fruitpunch.ben

macrumors 6502a
Sep 16, 2008
587
156
Surrey, BC
I am not trying to as a doubt question, so bare with me. But what is reloading the SL?? Is that the complete reload, and will I lose all my apps??

Thanks again...
sorry for being unclear, yes people have had a good experience completely reinstalling snow leopard.
You will lose everything you have installed since you got your computer.
I had assumed that as it was fairly new you shouldn't have any difficulty...
 
Comment

Similar threads

  • Vince Uy
0
Replies
0
Views
31
  • xxtsxx702
0
Replies
0
Views
101
  • deltrotter71
8
Replies
8
Views
311
  • Silenus3
1
Replies
1
Views
301
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.