New IMAC 27in will not go into sleep mode!

Discussion in 'iMac' started by cannonierd, Oct 1, 2011.

  1. cannonierd macrumors newbie

    Joined:
    Oct 1, 2011
    #1
    Just looking for some help with this maybe its something that I am doing wrong. My IMAC just arrived today, I have a wireless keyboard and mouse from Logitech made for Mac installed. When i go to the Apple icon and try to put the computer into sleep mode it actually shuts off and the only way to get it to turn back on again is to hit the power button. I have done searches on this and have not found anything current, so I thought I would post here before I called AppleCare in the morning. Thanks for any advice you can give.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Try This

    System Preferences / Energy saver....Check the settings in there and adjust accordingly....They should be set at the factory, but you have OEM hardware there. If those settings are right and it still won't sleep, I'd contact Apple....It's brand new.
     
  3. cannonierd thread starter macrumors newbie

    Joined:
    Oct 1, 2011
    #3
    Still will not sleep on the phone with Applecare now, not sure even they can figure it out already done the SMC reset and the PRAM reset as well as Safe mode or safe boot. Aside form this hiccup this computer is awesome.
     
  4. cannonierd thread starter macrumors newbie

    Joined:
    Oct 1, 2011
    #4
    Ok I took it into the mac store and sleep mode worked then I took it home plugged everything in then it would not work again. Figured out that my a/c powered usb hub was causing problems and making the imac shut down. Now I have to find out why my wireless keyboard from logitech is trying to give me battery status on my solar powered keyboard and mouse when the mouse should not be getting read by the app.
     
  5. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #5
    Good luck! My iMac 27 (2011) at first slept and woke fine. For some reason (I have yet been able to figure out), it started having problems. Unlike you, though, mine wakes fine. The problem is, it never really goes to sleep.

    I hooked up a Kill-a-watt meter to monitor power consumption. When I put the iMac to sleep, or let it "time out" and sleep automatically, it appears to be asleep, but it's not. It's drawing 30-40 watts still, and when left overnight, the iMac chassis still slightly warm in the morning.

    Oddly, the same occurs in Windows (bootcamp). No real sleep. Monitor goes black, and it LOOKS like it's asleep, but it isn't.

    I've unplugged everything USB except my corded Apple keyboard and USB receiver for my logitech mouse. I have configured Windows to disallow power management interaction with mice (not sure how to do that with Mac OSX) and still Windows won't sleep.
     
  6. Rasan macrumors member

    Joined:
    Aug 18, 2011
    #6
    The Imac can be prevented form sleeping if you have shared folders or your internet connection. I have the same problem, my imac doesn't really sleep, it only pretends to. The screen goes black but i can still hear the HD once in a while. I think it is because of the sharing options, because i can still access internet sharing with my MBA when the Imac is put to sleep.
     
  7. cannonierd thread starter macrumors newbie

    Joined:
    Oct 1, 2011
    #7
    In the end it had nothing to do with shared files. Apparently my Imac does not like having a powered usb hub plugged in. In other words if I have the power plugged into the usb hub my Imac does not like that and shuts off when i put it into sleep mode. If I take the power plug out of the mix and just have the Imac powering the hub then I can go into sleep mode all day long and it will wake up when I want it to and function normally. Odd but its working so i wont mess with it....
     
  8. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #8
    Yu Will Hear

    The HDD from time to time, your iMac runs scripts when idle to keep things neat and tidy. I tend not to let mine sleep (Prefer to shut down when I;m done) So I use a third party app to run daily / weekly scripts when I want to.

    Onyx for Lion (free)
     
  9. siestaguy macrumors newbie

    Joined:
    Sep 14, 2007
    #9
    Thanks for posting that, you solved the mystery of why my imac immediately wakes from sleep. I unplugged the DLink 7 port powered hub and my imac won't have insomnia any more.
     
  10. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #10
    I have had problems with computer insomnia in the past caused by the following:

    • Wake on LAN access enabled
    • File Sharing enabled
    • NAT tunneling in router
    • A USB printer unless connected through an external hub
    • An external USB hub
    • A twitchy mouse (not Apple)
    • Dropbox with LAN sharing enabled
    • BetterTouchTool and BetterSnapTool
    • OS/X Lion 10.7.0 wouldn't sleep on 3 out of 4 of my systems converted to Lion

    Of course I've been sleeping desktop computers for about 10 years now and have a lot of experience with problems! Best bet is to disconnect everything and shut down all applications you can. If it then sleeps (and it probably will) turn on apps and plug in devices one at a time and check for sleep.
     
  11. ZMacintosh macrumors 65816

    ZMacintosh

    Joined:
    Nov 13, 2008
    #11
    I've noticed with Lion that even when I put a machine into sleep mode its still broadcasted on the network. so thats a possible solution there to disable or change the settings of Sharing your Mac on the network.
     
  12. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #12
    If it is broadcasted on the network it isn't asleep. A common Lion problem -- the Energy Saver sleep timer for the display works (so the system looks to be asleep) but the timer for system sleep doesn't trigger because something, somewhere is active. Lion does far more stealthy things than the predecessors.

    The network *should* not wake a sleeping system if the wake on LAN access is disabled in the Energy Saver preferences. However active servers on the system (DropBox, Plex, iTunes) *might* keep the system from sleeping in the first place. These things seem to share regardless of Sharing preferences.
     

Share This Page