New iMac i7 will not boot into Single User Mode

Discussion in 'iMac' started by Bill P., Nov 14, 2009.

  1. Bill P. macrumors regular

    Bill P.

    Sep 24, 2007
    I hold down the Cmd & S keys (just like on my older iMac) and after a delay it boots up as usual. I just got this iMac yesterday (brand new).

    I experienced the monitor going bland for a second a few times along with some other vertical lines and wanted to run the fsck function as I have on my other macs. No go....



  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Wireless keyboard?

    If so might have to plug one in a wired keyboard from the Mac in the closet.
  3. Bill P. thread starter macrumors regular

    Bill P.

    Sep 24, 2007
    Ah, good idea SB. Didn't have that problem on the old 20 incher....I'll give it a shot!

    Enjoy your Saturday!
  4. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Apple had that problem when the keyboards first came out, took awhile before they corrected it.

    Just figured that it would be typical for a new chipset and all the rewrites in the OS to cause the issue to pop up again.
  5. JDW macrumors 6502


    Jul 12, 2005
    Problem is not exclusive to wireless keyboards

    I have a wired Macally keyboard that I have been using with my March 2009 iMac 3.06GHz. I am also using the wired Mighty Mouse, connected to the keyboard. Never had any problems until today. I tried 2 times to boot into Single User Mode by holding down CMD-S. The OS just ignored my keyboard presses and booted back to the Finder.

    I then pulled the stock Apple keyboard (wired kind, without the numeric keypad). I then rebooted, quickly held down CMD-S, and to my surprised it worked. I got the command line. However, I then could not type anything. So I connected my Macally keyboard back (after having disconnected the Apple keyboard) and then I could type.

    Not sure what's going on here, but that is my experience.

Share This Page