New iMac - "Misting" problem on screen??

Discussion in 'iMac' started by nomad01, Jan 29, 2008.

  1. nomad01 macrumors 68000

    nomad01

    Joined:
    Aug 1, 2005
    Location:
    Birmingham, England
    #1
    Just wondering if anyone else has noticed this.

    Had a new aluminium iMac since October (ish) and just recently noticed a sort of misting effect along the top edge of the display. Noticable when the display is off mostly.

    Almost looks like smoke damage on the inside of the screen. The iMac is left on quite a lot. Wondering if its some kind of heat damage from leaving the machine switched on.
     
  2. Jasonbot macrumors 68020

    Jasonbot

    Joined:
    Aug 15, 2006
    Location:
    The Rainbow Nation RSA
    #2
    I think it's a common problem. Do you live in a humid area? its probably water vapour
     
  3. nomad01 thread starter macrumors 68000

    nomad01

    Joined:
    Aug 1, 2005
    Location:
    Birmingham, England
    #3
    Don't think it's a humid area. The "marks" remain there even after the machine has been off for a couple of days too. Presume water vapour would dissipate after a while??

    Steve
     
  4. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #4
    Do you smoke in your house? If you do, it could be from that.
     
  5. nomad01 thread starter macrumors 68000

    nomad01

    Joined:
    Aug 1, 2005
    Location:
    Birmingham, England
    #5
    No I don't smoke. Nobody in my house does. The iMac is stored in a dry, warm room (not overly warm) room.
     

Share This Page