New iMac/Mountain Lion: Wi-Fi Issues

Discussion in 'OS X Mountain Lion (10.8)' started by MsDalfo, Nov 23, 2012.

  1. MsDalfo macrumors member

    Joined:
    Sep 25, 2012
    Location:
    Texas
    #1
    Hi guys. I just got my iMac refurb in the mail the other day, and it came with Mountain Lion installed. That's cool; I'm still on Snow Leopard on my MBP.

    The only problem is that on the iMac, the wifi at my house works intermittently. It really varies, but the wifi will disconnect often enough to be obnoxious. Yesterday it was every few minutes; right now it's every 5-10 minutes or so. I never had these kinds of wifi issue on the MBP/SL machine, and I see others specifically having this issue when having upgraded from SL to L/ML.

    I tried googling my issue and while I see others having this issue, I couldn't find any definitive answers (here in this forum, or elsewhere). I did check for duplicate keychain entries for my router, and that isn't the issue (only one password in there for the wifi).

    Could anyone point me in the right direction? Thank you, I appreciate it.
     
  2. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
    #2
    WiFi in Mountain Lion is one of the universe's great mysteries. It works fine during high tides and odd days of the week.

    All my devices running Windows never have a problem. One Snow Leopard machine never has a problem. Just Mountain Lion. I recommend you sit close to the router hand put an on/off switch on it. :) At least 3 times a week I need to power mine off/on to get the ML machine working again.
     
  3. MsDalfo thread starter macrumors member

    Joined:
    Sep 25, 2012
    Location:
    Texas
    #3
    I am unfortunately not in the same room as the router.

    Thanks for the advice though. Appreciate it.
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    First on a Mac, if you live in a apartment building or close to many houses, download the iStumbler betas and see if your router is on the same wireless channel than those around you.

    Also try to go to System Preferences->Network and turn the Airport card off. Then at the top of the Network tab look for the "Location' pull-down. There make a Network Location custom named Location. Make sure you save this new Network Location (is the 'Edit Location' and use the + sign to make a new Location) at both places in the Network pane. Lastly just in the Network System Preference pane turn the Airport card back on and rejoin your wireless network. Don't worry, this custom named Location acts the same as the 'Automatic' Location.

    Lastly if you wireless router is more than 3 years old go into the router's configuration and set the MTU down from 1500. It seems some older routers can't do Jumbo Frames. See if that works for you.

    Good Luck.

    One more thing: Think of using an upper 5GHz channel (in the hundreds range) for the Mountain Lion Mac to separate from other wireless signals. This might help.
     

Share This Page