new iMAc Performance Issues? Try THIS

Discussion in 'iMac' started by DrNelly, Oct 31, 2009.

  1. DrNelly macrumors member

    Joined:
    Jun 13, 2008
    Location:
    NJ
    #1
    To all those suffering from performance issues with safari, flash and overall sluggishness of the system try to turn off Airport and turn it on again.

    After you turn Airport off the CPU (actually the core that goes through the roof) goes back to normal, and the system is smooth and buttery overall again.

    In my case CPU usage went from 68 to 1.25!! right after Airport was turned off.

    Please give it a try and report here if that works for you guys.
     
  2. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Joined:
    Dec 21, 2002
    Location:
    Yahooville S.C.
    #2
    I also have noticed some crazziness with airport lagging the system, almost like its looking for newtworks endlessly and turned it off and back on and noticed a big change. Snow leopard early bugs i guess. Everything was bogging down till i messed with airport.
     
  3. Leon575 macrumors member

    Leon575

    Joined:
    Jul 12, 2009
    #3
    Thanks for the tip.
    My iMac will be placed right next to my router anyway... so I might just turn AirPort OFF and connect to internet via cable.
     
  4. sharkync macrumors regular

    Joined:
    Aug 8, 2009
    Location:
    Raleigh
    #4
    Awesome info - this thread needs to be kept at the top so people can try this and report back.

    GOOD JOB!
     
  5. fr4c macrumors 65816

    fr4c

    Joined:
    Jul 27, 2007
    Location:
    Hamster wheel
    #5
    Tried it, but the issues comes back again after a few hours of use.
     
  6. JAWWC macrumors regular

    Joined:
    Jun 1, 2008
    #6
    Great tip for a temporary solution! Just used ethernet instead.

    Thanks!
     
  7. DrNelly thread starter macrumors member

    Joined:
    Jun 13, 2008
    Location:
    NJ
    #7
    Yeah the problem comes back because there is a memory leak coming from Airport drivers. I think it would be interesting to know if there are other actors involved in this issue, read graphic drivers, hard drive issues, etc.. it might be something else acting up besides Airport.

    Until Apple pushes an update, if your mac becomes a turtle this tip will put that turtle on steroids :)
     
  8. rmg007 macrumors member

    Joined:
    Aug 28, 2009
    #8
    Does the problem come back even if you leave airport off?
     
  9. DrNelly thread starter macrumors member

    Joined:
    Jun 13, 2008
    Location:
    NJ
    #9
    I can't test that with safari because I'm far from my router, but when I do other offline work no lag whatsoever, regardless of the application. So that's a good sign...
     
  10. jmonfire macrumors member

    Joined:
    Oct 28, 2009
    #10
    10.6.2

    You guys are just gonna have to wait for SL update 10.6.2
    which I think will in many ways, fix most of issues posted in the forum.
     
  11. otisblack macrumors newbie

    Joined:
    Oct 29, 2009
    #11
    Cool, this worked for me as a temp fix on my 27'' iMac. Thanks!
     
  12. ktolani macrumors newbie

    Joined:
    Aug 5, 2008
    #12
    i believe you really dont have to go upto turning yr airport off and back on. just click on the airport, and let the wireless list refresh with the circle thing rotating around on the top, once its done refreshing the network lists the circle will dissapear and the sluginesh nd lags goes away too. (just a simpler/faster way for the temporary fix rather than turning off and on)
     
  13. kelf macrumors newbie

    Joined:
    Oct 25, 2009
    #13
    can we possibly just turn off the "auto search" by some tweaking?...i mean im no expert on this front, but i cud do tht on my PC...so why not on the mac?
     
  14. sharkync macrumors regular

    Joined:
    Aug 8, 2009
    Location:
    Raleigh
    #14
    I hope you're right. But given past performance with 6.0 and 6.1 - I'm not so sure.

    We'll just have to wait and see.
     

Share This Page