New iMac Video Problem - This Content is currently unavailable

Discussion in 'iMac' started by hobbes1012, Nov 12, 2013.

  1. hobbes1012 macrumors newbie

    Joined:
    Nov 12, 2013
    #1
    Dear All,

    I purchased a new iMac last week and I have been using Macbook Pro before so this is my first iMac.

    I noticed a problem and I don't understand what is causing it. My iMac does not play videos from sites like History Channel's Pawn-stars. I believe I have problems playing Flash videos? When I click play, I hear a voice telling me "This Content is currently unavailable" after 2 seconds.

    Could you please assist me in fixing this problem

    Thank you
     
  2. TheyCallMeBT macrumors member

    Joined:
    Jan 9, 2013
    #2
    Have you tried more than one browser? Just to rule out if it's Flash problems that just the browser you're using has. If you're using Safari, try Chrome or Firefox.

    Otherwise, post a link and I'll see what it does for me.
     
  3. hobbes1012 thread starter macrumors newbie

    Joined:
    Nov 12, 2013
    #3
    I tried Firefox already and the same female voice says:

    "This Content is currently unavailable". The same female sound says the same thing on other websites too, so its not website related

    Here is a link to History Channel Pawnstars
     
  4. hobbes1012 thread starter macrumors newbie

    Joined:
    Nov 12, 2013
    #4
    I am really surprised that no one else is facing this problem. I believe it is a Flash problem but i checked Flash is updated, javascript is updated. I don't understand what the problem might be
     
  5. TheyCallMeBT macrumors member

    Joined:
    Jan 9, 2013
    #5
    That is really odd. That's it the same voice/ message, too. It's websites that aren't in the same parent company, right?

    It worked fine for me on my mid 2010 iMac, but that doesn't really mean anything. My new iMac should get to me on Saturday. If no one has any more info by then, I'll check it on my new one.
     
  6. hobbes1012 thread starter macrumors newbie

    Joined:
    Nov 12, 2013
    #6
    They are both different TV Channel Websites. Even my iPad plays the videos my iMac can't play

    My late 2013 iMac is a few days old so i needed to install Flash Player, Javascript as a basic setup. Am I missing something that needs to be installed?

    Is something conflicting with the Flash Player? Is there a default setting I need to change?

    Is there a general video playback issue with Mavericks or something?

    Really frustrating
     
  7. JamietheMac macrumors member

    JamietheMac

    Joined:
    Sep 5, 2010
    Location:
    Scotland
    #7
    just a thought what country are you in?

    i know in the UK we have blocked content from the USA

    just a idea
     
  8. Paul-B macrumors newbie

    Joined:
    Jan 2, 2013
    Location:
    Europe
    #8
    99.99% sure this is the reason. I get the message too. The only way round is getting a US IP...
     
  9. hobbes1012 thread starter macrumors newbie

    Joined:
    Nov 12, 2013
    #9
    I am currently in the US. Is there somewhere in the system I need to change the location? In System Preferences Language and Region seems correct. Is my iMac having problems with verifying my location? Maybe I need to switch location settings from somewhere in the system.
     
  10. hobbes1012 thread starter macrumors newbie

    Joined:
    Nov 12, 2013
    #10
    The playback issue is solved. Looks like Region was the problem. Even though my region is correct in the system preferences there was an 1 hour mistake in the "date & time section" For some reason it was set to Sydney Canada and just changing that solved the problem.

    I worked for hours with Flash Player, javascript preferences and in the end it turned out to be a location mistake. I don't know why on earth I was set in that location in the first place.

    It is really interesting to see how everything is connected to each other. One mistake in the time zone and videos stop playing

    Thanks for the assistance all
     
  11. CrickettGrrrl macrumors 6502a

    CrickettGrrrl

    Joined:
    Feb 10, 2012
    Location:
    B'more or Less
    #11
    I'm having the same issue with my 2011 iMac updated to Mavericks. I just checked my Date/Time settings and they're correct. Flash Player is updated, etc., For example, I can't watch the Atlanta Zoo panda cam on my iMac, but it works fine on my old iPad. Pop-up windows on some sites say I need to update to the most current version of Flash Player, even after I've just downloaded and updated it from Adobe's site.
     
  12. hobbes1012 thread starter macrumors newbie

    Joined:
    Nov 12, 2013
    #12
    Did you try uninstalling and installing flash again? Don't forget to restart your machine in between. You should use this website to download flash so you can choose your operating system and version manually.

    http://get.adobe.com/flashplayer/otherversions/
     

Share This Page