Resolved new iMac with fusion drive, partitions messed up

Discussion in 'iMac' started by iVoid, Jan 30, 2013.

  1. iVoid, Jan 30, 2013
    Last edited: Feb 23, 2013

    iVoid macrumors 65816

    Joined:
    Jan 9, 2007
    #1
    Okay, so I have a new iMac with a fusion drive.

    During testing of our standard image, somewhere along the line the core services volumes/partitions got hosed badly.

    It doesn't look like Apple's own Recovery partition has the capability to completely blank the two drives and reapply the factory standard hybrid partitioning.

    Basically, I'd like to completely blank the two drives so they have either no partitions or just two basic GUID partitions. From there I should be able to issue the command line tools to recreate the fusion drive partitioning.

    Right now, when I issue the "diskutil cs deletevolume #####" command I get the following error:
    Error: -69808: Some information was unavailable during an internal lookup

    If I do the "diskutil cs delete ####" command, I get the following:
    The volume "(null)" on disk## couldn't be unmounted.
    Error: -69886: Invalid Request

    I've tried it from a external boot drive, via target disk mode, and via Internet Recovery Mode. All give the same error.

    So somewhere along the line I messed up the partitioning. So far it doesn't look like Apple's GUI or terminal diskutil will allow me to partition them as single drives until it removes the core services volumes/partitions. Unfortunately, it won't let me do that.

    Does anyone have any ideas before I go to Apple for a fix?
     
  2. large farva macrumors regular

    Joined:
    Jan 14, 2013
    Location:
    Melbourne, FL
    #2
    I would just make an appointment at the Genius Bar at an Apple Store and say screw it. They might be able have it set and done bada bing badaboom. Rather than you hassling around with it and just getting yourself frustrated. If you are the type of person to get frustrated.
     
  3. iVoid thread starter macrumors 65816

    Joined:
    Jan 9, 2007
    #3
    Solved it without a trip to the 'genius' bar. :)

    Booted new iMac into target disk mode.

    Connected to Snow Leopard Mac.

    Used disk utility on SL (which has no knowledge of the Corestorage used in ML), and repartitioned both physical drives with a single partition on each.

    Then booted into Internet Recovery mode on the new iMac and ran Disk Utility there.

    It knew the fusion drive partition was broken and prompted me to fix it. I had assumed I'd have to do it from the command line, but the newest GUI Disk Utility obviously knows that it should be one logical volume and could fix it automatically one I blew away the old corestorage partitioning that was messed up.

    Useful to know for the future.
     

Share This Page