New iMovie makes my mac unusable, please help!

Discussion in 'MacBook Pro' started by al82, Nov 2, 2013.

  1. al82 macrumors regular

    Joined:
    Feb 13, 2008
    #1
    I need to do some very basic editing for a university presentation.

    I always used iMovie 09 and never had a problem. I tried using the new iMovie today for the first time and it is unusable. It is extremely slow. If i even press pause during the video it freezes for 5 minutes.

    The preview window shows the video stuttering (even though when playing the video on any player it is fine).

    It has become unusable. My macbook pro is a 2.8 GHz Core i7 with 4gig ram. I know it is not a huge amount of ram but I'm trying to edit a 5 minute video in iMovie and never had a problem with the old version.

    Is this a issue with the new iMovie?
     
  2. Snookerman macrumors 6502

    Joined:
    Jul 6, 2008
    #2
    Check the Applications folder. There should be a folder called iMovie with the old iMovie app in it.
     
  3. nilnova macrumors member

    nilnova

    Joined:
    Oct 30, 2013
    #3
    Sorry I can't help you with your problem, but my understanding is that the old iMovie is still installed in case you need to use that instead. For me on a new late 2013 rMBP I see iMovie 9.0.9 in the Applications folder when viewed in Finder. Maybe you can use that one to get your project done in the mean-time.

    Edit: I got snookered by Snookerman. I am too slow. :D
     
  4. al82 thread starter macrumors regular

    Joined:
    Feb 13, 2008
    #4
    Thank you for the help :)

    Went back to the old iMovie and everything is fine again. Went back to the old version of Pages as i would no longer automatically turn to a capital I when used.

    I love apple, but the new ilife and iWork's has been a big step back for me.
     

Share This Page