New install of leopard - constant password

Discussion in 'macOS' started by jmsewe0, Nov 2, 2007.

  1. jmsewe0 macrumors newbie

    Joined:
    Oct 12, 2007
    #1
    Guys, i bought a 20 inch imac last week, got my leopard DVD today and tried to install. The install went fine and i was forced to reboot. After the reboot, i now get a login screen. I never got a login screen before on 10.4. Well, i put in my password, and it looks like it is about to load up the OS, and then it prompts for the pw again! I tried to enter the password repeatedly, but after the 6 time, i got frustrated. If i enter the wrong password, the window shakes and clears out the field, so I know i have my password right.

    Anyone have these issues yet?

    Thanks for any help all! -Josh
     
  2. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #2
    Have you tried booting into the safe mode by holding down the shift key while booting? Try that once, then do a regular boot and see if the problem goes away. (Do permissions repair after that and reboot.)
     
  3. snickelfritz macrumors 65816

    snickelfritz

    Joined:
    Oct 24, 2003
    Location:
    Tucson AZ
    #3
    If your existing Tiger login password is longer than 8 characters, you won't be able to login to a Leopard "upgrade" installation.
    You'll have to reset the password using the password reset utility in the DVD installer menu. (Boot from the DVD by holding "c" at startup)

    This really should be more clearly documented; many users are going to run into this problem.
    Apple has already issued a software update that corrects this problem.
     
  4. NathanCH macrumors 65816

    NathanCH

    Joined:
    Oct 5, 2007
    Location:
    Stockholm, Sweden
    #4
    I wish you were right, but I've tried this. I reset my password to a three character password and I get the same result. The login works, but it goes to a blue screen for a second, then goes back to the login. Right, jmsewe?
     
  5. jmsewe0 thread starter macrumors newbie

    Joined:
    Oct 12, 2007
    #5
    Thats exactly right. My pw is only 6 chars long and it still doesnt work.

    SO after i made my post last night i did the permissions repair on the mac partition to no avail. This is really starting to piss me off. This is my first mac, and i dont want to regret the purchase. I guess i will try calling apple support today.

    If, i try to do a backup and then restore, i wonder if that would fix the issue?
     
  6. jmsewe0 thread starter macrumors newbie

    Joined:
    Oct 12, 2007
    #6
    Fixed

    Ok, guys, in case anyone is interested - i did a archive and install again, and it is working now. not sure what the issue was, but guess it works now!
     
  7. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    Glad that got worked out, and just for reference what was (I assume) happening was that the loginwindow process was crashing on login. When loginwindow dies, that user session is killed instantly--I've used that once or twice to revive a totally stalled login without forcing a full reboot, and I've seen it happen spontaneously a long time ago.

    As to why it was happening on login on a relatively clean install, NO idea, but it's obviously a sign of something pretty badly screwed up with either the OS install (which the archive-and-install would fix), or you'd installed something in 10.4 that was causing a MASSIVE crash on login under 10.5 (which the archive-and-install effectively removed).
     
  8. robinlovesunny macrumors newbie

    Joined:
    Nov 5, 2007
    #8
    agggh

    The same thing is happening to me. I am trying archive install now. I am so sad. Cleared my calendar and got a baby sitter just so I could play!:confused:
     
  9. meh macrumors newbie

    Joined:
    Apr 15, 2007
    #9
    I Am Not Impressed!!!!

    I am having the same problem


    this sucks
    :mad:
     
  10. lysolalley macrumors newbie

    Joined:
    Nov 5, 2007
    #10
    imac login woes

    I have tried the archive and install option recommended by Apple support but at the end of install the imac restarts, making it impossible to download imac 1.3 update and switch the login to automatic. After restart I have the same problem: a login that won't accept my password. Any ideas?
     

Share This Page