new internal hd in MBP... weird behaviour; help!?

Discussion in 'Mac Basics and Help' started by malch, Jun 16, 2009.

  1. malch macrumors 6502

    Joined:
    Jan 20, 2008
    #1
    Hi there,
    I just upgraded my hard drive from a 7200 RPM 200 GB to a 7200 RPM 500 GB internal SATA drive (Seagate Momentus). This in an Intel 15" MacBook Pro. Lots of reviews on newegg said this is a great drive.

    Before doing this, I cloned my 200 GB drive to the new one (via Super Duper) so I expected everything to work exactly the same way.
    But nothing's the same. Everything that used to just require one click of the mouse now seems to take two if not three or more clicks.
    If I have one note in Mail highlighted in the 'From' column, I can no longer check another note with just one click - - this actually seems to take three clicks.
    I just added the two hyphens in that last sentence, then wanted to move the cursor to the end of the sentence, to add a period... took two clicks to do it.
    The odd thing, too (I've been staring at the cursor more than usual these last few minutes) is that the cursor often stops blinking on and off.

    On top of this, at least one of my apps won't launch. By the way, I've repaired my disk permissions and rebuilt my Directory using DiskWarrior, to no effect.

    Does anyone have any ideas about what the problem might be? Can it really be the fact that this is a bigger, faster hard drive... that's not supported by Apple, perhaps?
    Thanks for any advice,
    malch
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    It being a large hard drive is not the cause. What you did, presuming the drive you cloned to was formatted correctly as GUID/HFS+, should have worked perfectly. You could check the drive compatibility database at XLR8YourMac.com for weird glitches with that specific drive, but I haven't heard of any.

    If it was just taking an abnormally long time for input to register, I'd say maybe the drive was flaking out on you and causing hangs. But if it's just clicking that isn't working right, and some apps won't open at all, it sounds more like something went wrong in the clone operation and you're basically running on a partly-broken OS install. Maybe try re-cloning with a different app? (I would try CarbonCopyCloner--it's free and I KNOW it works.)

    Question: Is Spotlight indexing? If SuperDuper doesn't clone over the index, that could take a while to rebuild, which can definitely cause slowdowns (though not broken apps)...
     
  3. malch thread starter macrumors 6502

    Joined:
    Jan 20, 2008
    #3
    Hi Makosuke,
    Thanks so much for your advice. I downloaded Carbon Copy Cloner, and went through the process again.
    But to my dismay, I'm still having to make multiple clicks to move from Mail to Safari, or to anything else. It's so aggravating.
    I'm tempted to put my old hard drive back in (that'll cost another hundred, because I don't want to risk losing AppleCare by attempting it myself), but now I'm afraid that my old hard drive will behave like this one!
    I now remember the oldest rule in the books, for me anyway, when it comes to computers: 'Be careful what you wish for'. Bigger hard drive? Sure. But is it worth having a computer that doesn't function properly? The answer is no.
    Don't know what to try next.
    Regards, malch
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    Okay, if you re-cloned from the original and it's still doing this, it seems unlikely the problem was software related, or it would have been doing it before. And it certainly shouldn't have anything at all to do with the new hard drive. Frankly, what seems most likely is that whoever installed the drive for you screwed something up with the trackpad when they were in there.

    Here are a few experiments to do:

    1) If you haven't already, reset the PRAM. Doubt it'll help, but who knows. You could also open up Disk Utility and try repairing permissions, though I doubt that'll do anything either. Again, no harm in trying.

    2) Find the install discs that came with the computer, and boot up from the "Hardware Test" disc (it should have instructions on the disc itself). Run the hardware test and see if it finds any errors. Not likely, but it won't hurt.

    3) Boot up from an OS install disc (either the one that came with it, or a Leopard disc if you bought one). Open up Disk Utility from the menu and run a check on your new hard drive from there, just to see if it finds anything. While you're booted from this disc, experiment and see if it's still taking multiple clicks to get one to register. If so, that completely rules out the hard drive as the source of the problem--it means you've got something else wrong.

    4) Since you were able to re-clone to your new hard drive, I'm assuming your old hard drive is in an external case of some kind. Have you tried booting from it? You should be able to go to the Startup Disk preference pane and select it as a boot drive. If it works fine when booted from the old drive in an external case... well, that would be weird. But it's something to go off of.


    Try some of those experiments to narrow it down.

    Also a question: What specific model of 15" MBP do you have? I'm assuming from your comment that it's not one of the newer ones with an easy-to-access hard drive. Note, though, that replacing your hard drive yourself does NOT void your warranty unless you break something while you've got the computer open (in which case the breakage isn't covered). If you know what you're doing it's probably not that big of a deal, but if you're inexperienced with tearing apart laptops, I can understand wanting to pay somebody else to do it.
     
  5. malch thread starter macrumors 6502

    Joined:
    Jan 20, 2008
    #5
    Hi Makosuke,
    Thanks again for your patience and generous advice...
    I've not been able to log on until now, because I ended up erasing my hard drive and re-installing Leopard from my install disk. Then had to install everything again, and of course, I lost email service, and ended up having to call (and change my password, etc.).
    Anyway, the good news is, as soon as I did the re-install, the mouse and cursor have been working perfectly.
    So — aside from all the time I lost — everything's fine again, and the drive is working nicely.
    Thanks again for your help and advice.
    malch
     

Share This Page