New iPad 2 won't update to 5.0????

Discussion in 'iPad' started by thaghost, Nov 4, 2011.

  1. thaghost macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Romeoville, IL
    #1
    I just bought an iPad 2 and registered it with my existing iTunes. I have been trying to update it to iOS 5.0, but it's not letting me. It keeps saying this device isn't eligible for the requested build.

    Any ideas?
     
  2. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #2
    1. If you just bought an iPad 2 from Apple, it should have come with 5.0. You can check this out by going to the About section found under the Settings app on your iPad.
    2. If you do not have 5.0 as you suggested, and it is causing the error which you suggested, then you should stop by the Apple store for them to check it out.
    This sort of issue is hard to diagnose on a forum as no one can really see anything happening.
     
  3. thaghost thread starter macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Romeoville, IL
    #3
    I've been buying iPad 2's for work this past month. This is the 3rd one I've bought. None of them had 5.0 installed on them. All had 4.3.3. I updated to 5 on the other 2 no problems. If I can't get it this morning, i'll swing by the apple store. Just doesn't make sense. I've had no problem updating my fiances ipad 2 to iOS 5, her iphone 4 and the 2 other ipad 2's i bought for work.
     
  4. leesweet macrumors demi-god

    leesweet

    Joined:
    Feb 1, 2009
    Location:
    Northern Virginia, USA
    #4
    Ditto. I've bought several for work also and just bought my own, too (sold an iPad 1), and all had 4.3. I always wondered how Apple upgraded instore stock, and the answer is, they don't, of course. How could they, in a sealed box? :)
     
  5. jsh1120 macrumors 65816

    Joined:
    Jun 1, 2011
    #5
    The problem you're reporting (not eligible for upgrade) was widely reported in the first few days after iOS 5 was released. If you haven't tried "restoring" the iPad according to the instructions on the Apple website, do so.

    Interesting that the iPad you have is 4.3.3 rather than one of the later revisions (4.3.4 or 4.3.5). That suggests it's older stock and as I recall the "not eligible for requested build" occurred most frequently among those who had not upgraded to one of those builds before trying to install iOS 5.

    In any event, now that the storm of requested upgrades has passed and the Apple servers should be able to cope with demand, your best bet (as you indicate) may be to go to the Apple store.

    http://support.apple.com/kb/ts1275
     
  6. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #6
    I suggest downloading the 4.3.5 firmware, manually upgrading to that (hold alt when you click restore if on mac, not sure bout pc). Then from there I imagine iOS5 will be less reluctant.
     
  7. MallCop macrumors 6502

    Joined:
    Jan 7, 2011
  8. clockworkorange macrumors regular

    Joined:
    Jan 31, 2008
    #8
    if you have used a jailbreak before and installed TinyUmbrella make sure to unclick the option to set it to Cydia servers upon exit.

    I had that same problem where it wouldn't upgrade but after doing that everything went smoothly on both my iPad 2 and iPhone 3GS
     
  9. steveca macrumors 6502

    Joined:
    Mar 9, 2005
    Location:
    Malta
    #9
    MallCop is probably right. I had the same issue as well with the ipad 1. Wouldnt get the iOS 5 so I restored rather than updated and it worked a charm
     
  10. Uln4321 macrumors regular

    Joined:
    Feb 3, 2011
    #10
    I bought a new iPad 2 from apple about two weeks ago online. It didn't come with ios5 and I was having the same peoblem. Just call apple and they will walk you through the steps. All we had to do was change the host files or something like that
     
  11. milo macrumors 604

    Joined:
    Sep 23, 2003
    #11
    If I got one with 4.3 I'd wait until 5.0.1 is out, there are some significant bugs. Until they're fixed I'd say having the previous version is a blessing.
     

Share This Page