New iPad (3rd Gen) Not Downloading Apps

randomguyishere

macrumors regular
Original poster
Jul 24, 2010
126
2
Whenever I download an app from the App Sore, the app shows up on my homescreen but stays on "waiting." after 5 minutes or so, the app finally downloads (sometimes... Other times it never starts).

Any idea what it going on and how I can fix this? I have tried logging out of my Apple ID on all computers and devices (MacBook Pro, iPhone 4S, and iPad 3) and logging back in, but this does not seem to fix the problem.

Thanks :apple:
 

gquiring

macrumors regular
Oct 19, 2007
195
0
SC
What is your Wifi connection like? Do you have a good signal? Run a speed test and see what you get.
 

randomguyishere

macrumors regular
Original poster
Jul 24, 2010
126
2
What is your Wifi connection like? Do you have a good signal? Run a speed test and see what you get.
Just did this and got 21.74MBps down, and 3.72MBps up. Apps download just find into my iPhone with this connection (and have no delay like on my iPad).

----------

What is your Wifi connection like? Do you have a good signal? Run a speed test and see what you get.
And all three wifi bars are white, indicating that I have the strongest signal possible on iPad.
 

kthankzbai

macrumors newbie
Feb 3, 2011
10
0
Yeah, I've been noticing that with mine too. Have to wait like 5 minutes sometimes for it to start downloading.

I thought it was just me!
It says waiting for a long time and my wifi signal is fine because my other devices connect and download instantly.

Don't know what the problem is..
 

hcherry

macrumors newbie
Mar 27, 2012
4
0
Same problem, apps not downloading

I've been dealing with the same issue. When I download an app from app store, it just says "waiting" until it gives me a "Cannot connect to iTunes store" message where I can either cancel or enter my Apple ID passcode again.

This has happened about five or six times in the past couple days.

I've got a strong Wi-Fi connection and have no problems browsing the web on my iPad or other devices.
 

SteveJobs2.0

macrumors 6502a
Mar 9, 2012
818
1,283
Just the sign of things to come my friends...

As for the issue, I fixed it by syncing directly with my iMac. It loaded the apps properly. I believe that one or more of the apps fail to complete during the installation process thus preventing other apps from loading.