New iPad (3rd Gen) Not Downloading Apps

Discussion in 'iPad' started by randomguyishere, Mar 21, 2012.

  1. randomguyishere macrumors regular

    Joined:
    Jul 24, 2010
    #1
    Whenever I download an app from the App Sore, the app shows up on my homescreen but stays on "waiting." after 5 minutes or so, the app finally downloads (sometimes... Other times it never starts).

    Any idea what it going on and how I can fix this? I have tried logging out of my Apple ID on all computers and devices (MacBook Pro, iPhone 4S, and iPad 3) and logging back in, but this does not seem to fix the problem.

    Thanks :apple:
     
  2. gquiring macrumors regular

    gquiring

    Joined:
    Oct 19, 2007
    Location:
    SC
    #2
    What is your Wifi connection like? Do you have a good signal? Run a speed test and see what you get.
     
  3. randomguyishere thread starter macrumors regular

    Joined:
    Jul 24, 2010
    #3
    Just did this and got 21.74MBps down, and 3.72MBps up. Apps download just find into my iPhone with this connection (and have no delay like on my iPad).

    ----------

    And all three wifi bars are white, indicating that I have the strongest signal possible on iPad.
     
  4. randomguyishere thread starter macrumors regular

    Joined:
    Jul 24, 2010
  5. kthankzbai macrumors newbie

    Joined:
    Feb 3, 2011
    #5
    Yeah, I've been noticing that with mine too. Have to wait like 5 minutes sometimes for it to start downloading.

    I thought it was just me!
    It says waiting for a long time and my wifi signal is fine because my other devices connect and download instantly.

    Don't know what the problem is..
     
  6. hcherry macrumors newbie

    Joined:
    Mar 27, 2012
    #6
    Same problem, apps not downloading

    I've been dealing with the same issue. When I download an app from app store, it just says "waiting" until it gives me a "Cannot connect to iTunes store" message where I can either cancel or enter my Apple ID passcode again.

    This has happened about five or six times in the past couple days.

    I've got a strong Wi-Fi connection and have no problems browsing the web on my iPad or other devices.
     
  7. SteveJobs2.0 macrumors 6502a

    Joined:
    Mar 9, 2012
    #7
    Just the sign of things to come my friends...

    As for the issue, I fixed it by syncing directly with my iMac. It loaded the apps properly. I believe that one or more of the apps fail to complete during the installation process thus preventing other apps from loading.
     

Share This Page