New iPad Mini 4 Can't Set Up

Discussion in 'iPad' started by CanadianEh, Oct 2, 2015.

  1. CanadianEh macrumors member

    Joined:
    Jan 17, 2009
    #1
    Just purchased a new iPad Mini 4. I currently have osx 10.6.8 and iTunes 11.4. When I try to set up my new pad it errors out with the error require most recent iTunes. I tried to upgrade iTunes but I get the outdated osx message. Which version of osx do I need in order to upgrade to the newest iTunes? Thank you.
     
  2. Eau Rouge macrumors regular

    Joined:
    Sep 21, 2013
    #2
    iTunes requirements can be found here.
    You need to be on at least 10.8.5.
     

Share This Page