Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

ac360

macrumors member
Original poster
Oct 2, 2018
50
40
I notice that all the third-party apps are loading, but none of them finish downloading or installing. Anyone experienced the same issue?
 

ac360

macrumors member
Original poster
Oct 2, 2018
50
40
After hours (and literally minutes after I posted earlier), the apps started downloading and installing. I guess a lot of patience is needed...
 

echo44

macrumors 6502
Jan 21, 2008
348
79
I am having the same problem started last night and now its morning only a few of my apps have restored. I have erased and reset twice? I have very fast internet? This has not been the easiest upgrade . My phone also came with a sim that needed manual activation unlike in the past.
 

DiCaprioAngel

macrumors 6502a
Jul 12, 2013
574
394
New York
Yes, I did notice that it took a while to download the apps, but all is well! I think it took a while because it was downloading the app as well as its saved data, if it had any. It was worth the wait though. I woke up this morning to all my apps, photos, and music all downloaded and ready to use!
 

ReallyBigFeet

macrumors 68030
Apr 15, 2010
2,935
101
I setup two new iP12ProMax units last night. Both had this issue where while downloading apps it would just stop. Via total random trial and error, I found if I paused a few and then restarted them, it “unsung” itself and everything else downloaded smoothly.

Now struggling with some FaceTime issues though. The image is super-pixelated.
 
  • Like
Reactions: DumbPhone

Jordan921

macrumors 603
Jul 7, 2010
5,069
2,166
Bay Area
Didnt have any issues with my apps not loading. This time around everything was pretty much effortless. Only had to change 1 password.
 

MacZonie

macrumors member
Nov 15, 2010
44
15
After the downloads had stuck at loading for 13 hours, I called Apple Care. The only solution they could offer was to set up the phone as a brand new phone and re-download every application and account. This is going to be a painful process! When I asked how could this happen, I was informed it could’ve been a virus or malware in one of the applications. Sounds like an easy answer!
 

MacZonie

macrumors member
Nov 15, 2010
44
15
So just for the heck of it, I erased the phone and tried the migration agaim. It went smoothly and all apps loaded correctly with all data intact! Might be worth a try if you run into a similar issue.
 

SAT-MrMike

macrumors newbie
Nov 20, 2020
1
0
Same issue with my 12Pro Max. None of the 3rd Party Apps were loading. I let the phone sit over night, several times, to no avail. I tried stopping multiple ones running at the same time, then just running one at a time, didn’t work. I reset the phone, started the import process again, a few more loaded. Even used a lightning cable from my IPad to the 12PMax. Still same issue after reset. I then uninstalled several of the apps, and reinstalled from the App Store. This worked well and remembered my settings / password on many of them. The ones that remembered my passwords were ones that I attempted to download initially.
 

may.you.find.a.light

macrumors newbie
Dec 16, 2020
1
0
Just read this thread because I was having the same problem! Paused all the downloads, then went and un-paused them and now it's flying through the apps! I think it had everything downloaded but wouldn't install them, since my internet isn't THAT fast.
 

gwynna

macrumors newbie
Jul 29, 2011
3
0
uk
When I press “get” I get a spinning wheel and then nothing else. Have tried logging in and out of App Store, soft reset of phone, checked enough storage, no restrictions to download in settings and still nothing. Anyone else had this issue and if so, apart from doing a hard reset what can I do?!
 

Majstor

macrumors newbie
Apr 22, 2021
2
0
Serbia, Belgrade
I had same problem, Laoding Apps for hours but not finished. Restarting several times did not make result. Finally I click on App Store and all Applications started and finished loading.
 

Darlene42303

macrumors newbie
Jun 8, 2021
1
0
When I press “get” I get a spinning wheel and then nothing else. Have tried logging in and out of App Store, soft reset of phone, checked enough storage, no restrictions to download in settings and still nothing. Anyone else had this issue and if so, apart from doing a hard reset what can I do?!
Did you find a solution to fix this problem? I just got a new 12Pro and I am having the same problem with about 5 different apps that were on my old phone. They do not show being on my new phone & when I hit "get" in the store nothing happens.
 

EssModelsRule

macrumors 6502
Dec 28, 2017
309
224
Same issue for me, all apps on 12 Pro stuck in "Loading" status overnight. Tried the App Store trick, closing all open apps in background, powering off a couple of times and nothing worked. I eventually wiped the phone and set it up again, but instead of using my old phone to transfer everything over, I restored from an iCloud backup. That worked, although not flawlessly as I had to reset my watch to get it to pair to the new phone.
 

jhahnde

macrumors newbie
Jun 22, 2012
2
0
I twice had this problem. First iPhone migrated with quick start. After Firmwareupdate and transfer of data the first reboot showed some problems with the apple id. I had to reenter the credentials. After this every third party app was stuck in "Loading". Same as you all here describe. If I tried to download an already bought app by clicking on the iCloud-Download icon it becomes a spinning circle for some seconds and then it switched back to the download icon again.

I did some thing with App Store logout and reboots of the new phone. After some time (some hours) it worked and all apps started downloading. So all went ok.

The second one was more difficult. Nothing worked over several hours. So I decided to reset the phone and try an iCloud restore. This worked fine - but some local content was missing. So I reset the phone and tried quick start again. This time - all worked instantly. Except the apple watch - it has to be unpaired and paid again.

There is something wrong with quick start. I changed many phone over the last years - this is new. It usually was a pain free process.
 

Majstor

macrumors newbie
Apr 22, 2021
2
0
Serbia, Belgrade
I had same problem, Laoding Apps as spinning wheel for 6 hours but not finished. Finally I click on App Store, wait minute or two, and all Applications started and finished loading. Finaly problem solved.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.