New iPhone 3GS not syncing properly

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MythicFrost, Feb 5, 2010.

  1. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #1
    Alright, my dad and I both have new 3GS's, they worked just fine. I updated iTunes and iPhone OS 3.1.3 and I'm going great. He did the same thing, but his iPhone won't sync properly.

    He sync'd his music and podcasts to it first, and then was syncing apps and soon as he clicked Apply all the 3rd party apps he had set to get sync'd to his iPhone just disappeared and left only the Apple apps on there.
    It shows only like 16.9GB available, on his 32GB iPhone 3GS when I check "About" under General in Settings, but it says there are no songs, podcasts (no movies or anything else either), and only one photo.

    Anyone have any idea what's wrong?

    EDIT: it keeps saying that he's not authorised to sync this content, he's tried going to Store > Authorise Computer and it just says "We could not complete your iTunes store request. An unknown error occurred (-42408). There was an error in the iTunes store. Please try again later.
     
  2. camarobh macrumors 6502

    Joined:
    Jul 17, 2007
    Location:
    San Diego, CA
  3. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #3
    Yes, as said above restore the phone, some crazy random and highly unlikely rare error probably occurred. Just restore and try again.
     
  4. MythicFrost thread starter macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #4
    We've restored and set it up as a new phone twice, it won't let him put the content on his iPhone. Under iTunes > About it shows version 9.0.1, but "Installed Software" under Software update in the System Preferences shows that 9.0.3 was installed, software update also says he's up to date.

    He's restored the iPhone about 5 or 6 times now. He was authorised to do this stuff before he installed iTunes 9.0.3 which says it's 9.0.1 from in iTunes.

    EDIT: Trying to re-install iTunes 9.03 at the moment, it has successfully installed iTunes 9.0.3, but it still says it's iTunes 9.0.1 from within iTunes under About.
    This is really really weird, iTunes isn't installing properly



    EDIT 2: This is getting more and more complex...
    So although iTunes 9.0.3 has been installed via Software Update and by me downloading it again from Apple.com and installing it, still shows under About as iTunes 9.0.1.

    He can't sync any apps or videos to his iPhone, because it says "He's not authorised", if I try and authorise/de-authorise it gives me error (-42408),
    I tried deleting the "SC" folder, quit iTunes restarted it, authorised it and this time it said "You have two computers authorised, including this one".
    I waited until the now 7th or 8th restore finished, tried to sync one app, and it said "You are not authorised".

    He also can't sync any songs (or podcasts), the songs show up on the capacity bar as 1.19GB of audio but if I go into the iPhone and into the iPod application it says there is "No content".
    It also says under Settings > General > About that no songs are sync'd.

    I am able to sync notes, calendars, contacts, photos, e-mails etc...

    EDIT 3: When I connect his iPhone to my computer my iTunes (9.0.3) the capacity bar shows 1.38GB as Other (it's seeing the 1.19GB of music that was previously installed, as Other instead of Audio), I'm trying to restore it on my iTunes right now.

    EDIT 4: it appears to be fixed, he had multiple versions of iTunes installed (since he put his iTunes in a different folder) the iTunes icon launched the old iTunes, even though the new was installed. it's working now.
     

Share This Page