New iPhone 4 - can I install 4.01 rather than 4.02? (Vodafone UK user)

Discussion in 'iPhone' started by jb7, Aug 16, 2010.

  1. jb7 macrumors member

    Joined:
    Jun 26, 2010
    #1
    Hi, my iphone 4 came today and I would like to jailbreak it. Essentially I just want to copy everything over from my jailbroken 3gs (iOS 4.0.1)

    But now that 4.0.2 is out, when I click 'update' itunes wants to install 4.0.2....Is there any way to make it install 4.0.1?

    thanks
     
  2. Shasta McNasty macrumors 6502a

    Shasta McNasty

    Joined:
    Jan 5, 2010
    Location:
    Southern Cali
    #2
    Search around on google, or ask this is the hacks section. There should be a way though.
     
  3. cambookpro macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #3
    No, but surely can't you just restore from a backup of you 4.0.1 3GS and rejailbreak it?
     
  4. anthdci macrumors 6502

    Joined:
    Jun 8, 2009
    #4
    try doing a restore using 4.0.1. download the files (there is a list of locations on iclarified) hold shift and click restore in itunes then point it to 4.0.1. Also download firmware umbrella to make a backup of your shsh blobs for 4.0.1 so you can restore when apple stops signing it and makes you go to 4.0.2. I dont think they have stopped signing in 4.0.1 yet
     
  5. Woomy123 macrumors regular

    Joined:
    May 12, 2009
    #5
    If your iPhone is on 4.0, jailbreak it now save ur shsh blobs with saurik then update manually by downloading the ipsw file from iclarified
     
  6. jb7 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #6
    thanks for the replies, I'm guessing this is the site:

    http://www.iclarified.com/entry/index.php?enid=750

    and the firmware I need is:

    4.0.1 (4): iPhone3,1_4.0.1_8A306_Restore.ipsw

    I'm not sure about this "firmware umbrella" works but I guess I just need to take one step at a time... shall I jailbreak on jailbreakme.com first?
     
  7. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #7
    Hurry up and downgrade now, Apple is still signing 4.0.1 SHSH blobs last time I checked.
     
  8. jb7 thread starter macrumors member

    Joined:
    Jun 26, 2010
    #8
    Can I do this yet though? My Cydia says "This device has a pending TSS request"
     
  9. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #9
    I assume, since you have Cydia, that you've already downgraded. As such, you just need to wait for the request to go through with Cydia. As long as you don't update until a jailbreak is available for whatever firmware Apple come out with next (there will be no 4.0.2 jailbreak), you won't even need that, but of course it's always good to have.

    I recommend installing PDF Patcher from Cydia to fix the exploit used by JailbreakMe, though, as malicious hackers could potentially use it without your knowledge.
     
  10. ToroidalZeus macrumors 68020

    ToroidalZeus

    Joined:
    Dec 8, 2009
    #10
    Just use tinyumbrella to save the SHSH to your PC and start the fake server. You'll need it anyways, to kick the device out of recovery mode, once iTunes gives you the error.
     
  11. Hakushox macrumors member

    Joined:
    Jun 22, 2010
    #11
    I restored my phone today to 4.01 without any additional software. Just stuck it in DFU mode and used the shift restore method.
     

Share This Page