New iPhone, iMessage stuck on Waiting for Activation

Discussion in 'iPhone' started by dontwalkhand, Nov 4, 2013.

  1. dontwalkhand macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #1
    This is annoying, and AppleCare tells me to wait 24 hours? Something doesn't jive. I have tried everything, from restore as new iPhone to restore from backup to reset network settings. Nothing works. Sometimes I would get the message "An error occured"...lovely
     
  2. dontwalkhand thread starter macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #2
    This is all I get.
     

    Attached Files:

  3. pookie82999 macrumors newbie

    Joined:
    Nov 4, 2013
    #3
    I had the same problem.... I found this in another forum and it worked for me.

    First go to settings, then to cellular and turn of cellular. Then I went to setting-general-reset and reset network settings. I just did this a few hours ago and it worked. I think you lose your saved wifi settings, however I am not home yet so I'm not sure.
     
  4. dontwalkhand thread starter macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
  5. Silverbird0000 macrumors 6502a

    Joined:
    Sep 19, 2006
    Location:
    Fort Myers, FL
    #5
    Turn off iMessages, and FaceTime, log out of iTunes/App Store and log out of iCloud. Go to settings, general, date & time. Make sure set automatically is turned on (if not turn it on). Restart phone. Then log back into each of the things above starting with iMessages. Also, do you have an active data connection with Sprint?
     
  6. dontwalkhand thread starter macrumors 601

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #6
    Yes I do have all the required Sprint plans.

    I've tried to log out of iCloud but I don't see where you can do so. But logged out of everything else and it still doesn't work :-(
     
  7. Silverbird0000 macrumors 6502a

    Joined:
    Sep 19, 2006
    Location:
    Fort Myers, FL
    #7
    Settings, iCloud, click your AppleID. Then sign out. You can also try taking the sim out and activating iMessages using just your AppleID. If it is still not working make and appointment at the Genius Bar in your area. It is possibly a hardware replacement.
     

Share This Page