New iPod 2G won't connect to internet

Discussion in 'iPod touch' started by coleym, Sep 15, 2008.

  1. coleym macrumors newbie

    Joined:
    Jul 11, 2008
    #1
    Ok, so I just got my shiny new 32 GB iPod touch and everything is going well. Sound buttons are cool, I now have all my songs, video, apps, etc all moved over to it. Things are great.....

    That is until I go about getting it setup on my wireless network. I go in, choose the network, type in the password and it shows that it is connected. However when I try to load a webpage on safari, it says that it can't connect to the internet. I know it's not my router because my old iPod touch, 2 laptops, and a desktop are all connected just fine (I'm typing on the desktop now). I tried to disconnect and try it again with no luck. I've tried turning the wireless adaptor off, and then back on. Turned the iPod off then back on. Nothing works. Also none of the apps I have will connect to the internet, so it's not just safari.

    I am out of ideas so if anyone can help me, I would certainly appreciate it. Thanks for any advice.
     
  2. seamustry macrumors member

    Joined:
    Aug 12, 2008
    #2
    do you have WPA security? i read somewhere that new touches are having problems with WPA...
     
  3. coleym thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    #3
    Yes, I am using WPA. Is there anyway to fix the problem?
     
  4. iTouch1987 macrumors member

    Joined:
    Sep 10, 2008
    #4
    what kind of router do you have?

    mine is a 2Wire and it has two access points with two different passwords located on the router itself.

    "System Password"
    "Wireless Network Key"

    try both combinations.

    the access point i usually use for laptops and my xbox 360 didn't work with my touch, however i tried the other one and i works dandy.
     
  5. coleym thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    #5
    I reset my router and altered the security on it and my iPod and now it works fine. Had to redo my e-mail accounts, but everything is connecting now. Thanks for the help.
     
  6. ctimk84 macrumors newbie

    Joined:
    Sep 22, 2008
    #6
    Well, the 2g itouch is my first itouch and i'm just having a terrible time trying to connect to the internet. At home at times I can connect and at times I can't. However I can't seem to get on youtube at all. I visited my local library today and it won't even pick up a network to connect to. I really don't know what to do...
     
  7. ctimk84 macrumors newbie

    Joined:
    Sep 22, 2008
    #7
    Went to this place with internet and couldn't connect. I guess I'll try another hot spot tomorrow. I"m starting to think there is something with my iPod touch. It's not even picking up any networks at times.
     
  8. farleysmaster macrumors 6502a

    Joined:
    Feb 8, 2008
    Location:
    London, UK
    #8
    I've had a similar issue, with the iPod needing to be prodded to connect to my network. The network name is ticked, however there's no signal bars in the top left hand corner of the screen. If I leave it for a few seconds, then turn off the wifi then on again it usually connects and stays connected. I've also tried renewing the DHCP lease, but I'm not sure whether that helps, or just the action of turning it off and on again.

    When you say it shows you are connected do you mean the network name is ticked, or the wifi signal bars are in the top left corner, or both?
     
  9. acdana macrumors newbie

    Joined:
    Aug 3, 2008
    #9
    I don't think it is your network

    I just bought two itouch 2g's for my twins. One connected to the wifi and the other won't unless i turn off the password. I also have two iphone 3g's and both of them connected fine to my wifi. I called apple today and got very little help but after denying they had ever heard of the problem at first, finally admitted it was a known problem and i will have to send the defective one back to the apple store.
     

Share This Page