New itune purchase "not authorized to play" on my iMac

Discussion in 'iMac' started by sapsjr, Apr 28, 2011.

  1. sapsjr macrumors newbie

    Joined:
    Dec 19, 2008
    #1
    (I have an iMac. I wasn't sure where to post this)

    Sometimes when I buy an album in the itune's store there are certain songs that itune's wont let me play.
    I get this message:

    This computer is not authorized to play "Sunset Soon Forgotton". Would you like to authorize it?

    I just bought this 10 min. ago. If I log in and click "Authorize" it tells me that this computer is already authorized and the song still wont play. This has happened on 2 of my last 5 purchases. Everything has been purchased and is exclusively used on my iMac.

    Does anyone know how to fix this? I tried searching the forums and Google but can't seem to find a fix for this. I'd appreciate a little help :)
     
  2. phlydude macrumors regular

    phlydude

    Joined:
    Jun 21, 2010
    Location:
    Newark, DE
    #2
    Just throwing out a shot in the wind here but would deauthorizing all computers on the account and then re-signing in fix this issue?
     
  3. sapsjr thread starter macrumors newbie

    Joined:
    Dec 19, 2008
    #3
    Thanks for the suggestion. I did try that. I just tried again. Still no luck. It still tells me it's not authorized to play.

    I also deleted the hd/library/cache folder and repaired disk permissions.
     
  4. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #4
    Wait a sec. I thought that any iTunes music purchase in the past 2-ish? years was DRM-free. I know TV Shows/Movies are still protected but I thought that music was supposed to be DRM-free.
     
  5. sapsjr thread starter macrumors newbie

    Joined:
    Dec 19, 2008
    #5
    Yeah I think it is. Everything plays whether the computer is authorized or not. It's just these 3 damn songs that won't. It's frustrating because one of the songs is what made me purchase the album earlier...and I can't even listen to it.

    I'm going to try syncing it with my iPod and see what happens.
     

Share This Page