New Jailbreak "SHAtter" will work on Current locked iPad (3.2.2) no need to wait

Discussion in 'iPad Hacks' started by maturola, Sep 9, 2010.

  1. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #1
    It's so quite in here, we need more iPad hackers on this section!...

    Anyways to the real juice, the Bootrom exploit found by @ipd2g will also be compatible with the current iPad running 3.2.2 (for those like me that had no choise but to return their jailbroken iPad and get a new replacement with 3.2.2 already on it :mad:).

    I think this is the first time I've been so impatiently waiting for any jailbrake and I've been Jailbraking since day one, been jailbreaking devices since the original Dreamcast :D:D:D

    Edit: sorry I left the source out

    Source: http://chronic-dev.org/blog/2010/09/pwned-once-again/

    [​IMG]
     
  2. iamthekiller macrumors 6502a

    Joined:
    Feb 3, 2010
    #2
    Ahhhhh, source?

    I jailbroke my 3.2.1 iPad the day I took it out of the box, but a foldersSB screwup forced me to restore to 3.2.2 and it was too late for cydia to have signed my 3.2.1 :(

    There aren't too many jailbreaking advantages on the iPad though. If I could only keep one item jailbroken, I'd much prefer my iPhone4 and would rather just have official 4.2 on the iPad.
     
  3. mrathee macrumors 6502

    Joined:
    Jul 8, 2010
    #3

    +1 for that. I can't wait for 4.2. My iPad is jailbroken for multitasking, sbsettings, and iconoclasm. Though, to be fair, I have scaled down my theme-ing on iPad because it starts to slow down with a theme+several apps running. (obviously)

    Once folders are out, I will jailbreak just for sbsettings and infinifolder. And absolutely nothing else.

    So glad it finally has a real release planned.
     
  4. maturola thread starter macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #4
    I can't stand my iPad on Stock FW, Backgrounder, SBSsttings, InfoShade, BT stack, Tethering, Categories, iFile, Attachment server, Download manager, I just can't live without these feature for my day to day activities. It's Drivimg ne so crazy.
     
  5. Carl G35c macrumors 6502

    Joined:
    Aug 14, 2008
    #5
    I cant wait, hopefully the same jb will work on 4.2 (doubtful)
     
  6. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #6
    This is awesome news. Having just purchased an iPad I was lucky enough to get it on 3.2.1 but this obviously meant that my SHSH couldn't be saved for this version. In the event I need to restore, I'm screwed.

    I will probably wait until 4.1/2 to come out before I upgrade though tbh as I don't have any problems with 3.2.1 other than wifi signal sometimes.

    Dont fix it if it ain't broke!
     
  7. maturola thread starter macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #7
    Lucky you! :p

    I believe the JB should be 4.2 compatible using a custom IPA, since it is a bootrom exploit, as long as you don't do a iTunes update to 4.2 I beleive it should stand :D:D

    I can't wait my iPad is :(
     
  8. wingsabr macrumors 6502

    wingsabr

    Joined:
    Dec 13, 2008
    #8
    As one of the unlucky ones who got an iPad with 3.2.2 I'm looking forward to this jb. I need my sbsettings and bg.
     
  9. oli356 macrumors 6502

    Joined:
    Sep 6, 2010
    #9
    I screwed up restoring so now im on 3.2.2 aswell and not liking it.... that was a few days ago.. thought i could be waiting for months.. hopefuly this all works :D
     
  10. dowbrandon macrumors newbie

    Joined:
    Sep 9, 2010
    #10
  11. iamthekiller macrumors 6502a

    Joined:
    Feb 3, 2010
    #11
    Almost everyone says no, but if it actually works for some, it sounds like their ipad must have ONCE HAD 3.2.1 running (and possible once jailbroken before also? if so, with which method?). For ipads shipped with 3.2.2, I believe that's one of the things preventing it from working.

    There is so much unknown with this exploit. Any takers want to try?
     
  12. maturola thread starter macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #12
    I tried that, and many others out there, It doesn't work without SHSH at least on fresh iPads with 3.2.2 never JBed, Some people had reported success most of them have been JB before
     
  13. oli356 macrumors 6502

    Joined:
    Sep 6, 2010
  14. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #14
    Can someone clarify if 4.1 is/will be available for iPad or is it only 4.2 that will be available for iPad in November?

    I only ask before I don't want to update to 3.2.2, even with this new jailbreak, but if I have to update due to needing a restore then I'm wondering when the newer firmware will be compatible.
    Native multitasking and folders is something I really would like on my iPad although multiflow is nice.
     
  15. earthdan macrumors member

    Joined:
    Jun 14, 2009
    #15
    I got my ipad a few days ago and I honestly can't remember if it had 3.2.1 on it first. I may have upgraded the firmware when registering the device etc. (I probably should have been paying more attention but I was too antsy to start playing with it!!).

    My question is, if I attempt to jailbreak (either straight up or by downgrading to 3.2.1 and then jailbreaking) and it doesn't work, will I have screwed up my ipad forever?

    I realize that this thread has indicated some development on the new jailbreak technique but I would like to jailbreak the ipad now!.....Obviously I can wait but my curiosity might get the better of me. Just want to know if I will screw it up in any way permanently.

    cheers,
    Dan
     
  16. maturola thread starter macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #16
    If you in fact upgraded it to 3.2.2 and didn't save your SHSHs using tinyUmbrella or Cydia them you are stuck until SHAtter is release.

    The only way to downgrade is to have the SHSHs on file and based on what you said, you didn't save them.
     
  17. Critical Hippo macrumors member

    Joined:
    Sep 14, 2007
    #17
    4.1 is for the iPhone only. The iPad will remain at 3.x (probably 3.2.x) until the release of iOS 4.2 in November.
     

Share This Page