New keyboard, Old forward delete problem...

Discussion in 'Mac Basics and Help' started by baloophi, Apr 16, 2009.

  1. baloophi macrumors newbie

    Joined:
    Apr 16, 2009
    #1
    Just bought the new wired aluminum keyboard (no number-pad) and have it connected to my Macbook via the Logitech notebook stand, but I can't get "forward delete" to function. No amount of fn + delete action will get it to delete to the right.

    I'm running 10.4.11 for what it's worth...

    Thanks in advance for any and all expertise.
     
  2. JustGretchen macrumors 6502

    Joined:
    Dec 2, 2008
    #2
    strange, should be FN + Delete...just like on any apple portable. I use one every day, it works for me. Maybe bad FN key? Does it work for other functions?

    You could also try calling 1800 APL CARE and see if they have suggestions.
     
  3. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #3
    Is there a way to bypass the Logitech notebook stand to see if it is causing the problem?

    Do all of the function and other keys work properly?

    Woof, Woof - Dawg [​IMG]
     
  4. baloophi thread starter macrumors newbie

    Joined:
    Apr 16, 2009
    #4
    Thanks for the responses.

    I bypassed the Logitech stand and still no dice.

    Then I tried other functions with the fn key... nothing. Strange - one key doesn't "function." Irony. Can/should I just take this thing back to Mac and swap for a new one?
     
  5. baloophi thread starter macrumors newbie

    Joined:
    Apr 16, 2009
    #5
    update...

    Just in case anyone was awaiting results of this issue...

    I exchanged the keyboard for a new one and experienced the same issue (no functionality from the fn key). I called Applecare and stumped the genius until I noticed - in very fine print - on the packaging that it requires OS X v.10.5.6 or later (I'm running 10.4.11).

    I'm going to try Leopard out when it arrives next week and report back in. I realize this a very specialized problem, but just in case it crops up for someone else...
     

Share This Page