New life for a discarded MacBook. Is this possible?

Discussion in 'MacBook' started by skeet73, Mar 10, 2008.

  1. skeet73 macrumors newbie

    Joined:
    Mar 10, 2008
    #1
    Relatively new to Mac.

    I own a Macbook and I connect to the internet via an airport express that runs through the wireless router that verizon supplied using an ethernet cable. I purchased the express in order to wirelessly play Itunes and print.

    Recently I bought another macbook with a cracked lcd screen (otherwise fine) from a friend of mine for fifty dollars with the intention of creating a network and using it as a server in order to access my external hard drive. After fooling with this for a day or two I have the network in place, that was easy, but I still can't get the external hard drive to show.

    My question is:
    Is this even possible with the airport express or do I need the extreme to access an external hard drive connected to a computer in a network. Quite possibly I just haven't fooled with it enough.

    This is my first posting. Hope I provided enough info.
     
  2. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #2
    I'm not sure I fully understand...

    Is your external hard drive connected to the MacBook with cracked LCD? If so, yes, you can access them from your not-broken-MacBook. Do the following:

    1. On the broken-MacBook, go to System Preferences -> Sharing.
    2. Select the "Services" tab.
    3. Put a check next to Personal File Sharing.
    4. On the not-broken-MacBook, go to Finder and click on the "Go" in the menu bar.
    5. Select "Connect to server..."
    6. In the "Server Address:" section, type in the IP address of the broken-MacBook and click on "Connect" button.
    7. All the drives on the broken-MacBook should show up in a new pop-up window.
    8. Select the drive you want and enter username/password.

    The drive should now show up on your desktop.

    I hope I answered the right question...
     
  3. SwiftLives macrumors 65816

    SwiftLives

    Joined:
    Dec 7, 2001
    Location:
    Charleston, SC
    #3
    First of all, make sure the external drive is mounting on the desktop of the computer you want to use as a server. If it's not, you might want to try another cable or port. Firewire will be your best bet, followed by USB2.

    You may have already done this, but here's something else to try:

    In the menu, go to:
    Apple -> System Preferences -> Sharing (third row)
    - make sure the box next to 'File Sharing' is checked.

    Let me know if that works. There may be a couple of more things to tinker with if it doesn't.
     
  4. skeet73 thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    #4
    Thank you.

    I have allowed file sharing on both MB and can see the network icons on the working mb. When I click on the desktop folder for the broken mb it shows an empty folder even though I can see that the ext HD is showing on the broken MB desktop when I go over to it. I even put a file on the broken MB's desktop to see if I could find that and I can, but still no ext HD. Hope I am being clear enough.

    The ext HD is connected through usb to the MB with the broken screen, and is showing on the desktop through the cracks.

    File sharing is turned on for both MB's.

    I can access everything on the broken MB except the ext HD.

    Thanks again. Knowing it's possible is half the battle. I'm probably overlooking some minor detail.
     
  5. jahala macrumors regular

    Joined:
    Feb 7, 2008
    #5
    Everything is working exactly as it should. For arguments sake, let's say the user of the broken macbook is mbbroke. When you turn on File Sharing, OS X shares the folder located at /Users/mbbroke. The desktop is found at /Users/mbbroke/Desktop. The problem is that although the external hard drive shows up on the desktop, it is not really mounted there. If the external drive is named EXTHD, then it is mounted at /Volumes/EXTHD and OS X puts an icon for it on your desktop. Since /Volumes/EXTHD is not a subfolder of /Users/mbbroke, you cannot access it from your shared home folder.

    There are two ways to fix this. In the File Sharing dialog, I believe there is a plus sign you can click on to add folders to share. It is reported to work, but I have not tried it. I usually use the following method because I only have to connect to one shared folder to access everything. I don't know which one you will like better.

    If you want to access the external HD over the network, create a symbolic link to it somewhere in your home folder. I have done this many times and it works great. I usually put the link in my home folder instead of the Desktop because it is one fewer thing to click on. The easiest way to make sure this works is to open Terminal (Cmd-Space for spotlight, then start typing Terminal) and type in the following command and press enter at the end:

    ln -s "/Volumes/EXTHD" "EXTHD"


    Substitute EXTHD with the name of the hard drive. The quotes make sure spaces in the hard drive name won't be a problem. Unless you have changed your terminal settings, this will create a symbolic link (like an alias, but works better) that will appear in your home folder as a folder called EXTHD. Opening that folder is the same as opening EXTHD. If you delete that folder (which is really the symbolic link), the link will be deleted. The drive will not be ejected.

    I hope that helps.
     
  6. skeet73 thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    #6

    Thank you for such an informative answer.

    I have never messed with terminal. Never even knew what it was for. After some quick searching I assume it's Unix which I guess is like programming language.

    I'm learning stuff this is good. Perhaps not fast enough. I tried typing in the command exactly as you showed, but the icon for exthd did not show in the home folder. I did use the exthd's name as you stipulated.

    I was to type this command into mbbroke' terminal, correct?

    I think I understand your recommended fix and I would like to go that route, I think I must be typing the command in incorrectly.

    In -s "/Volumes/LACIE" "LACIE"

    Is this right?

    Thank you for your patience.
     
  7. jahala macrumors regular

    Joined:
    Feb 7, 2008
    #7
    Yes.

    Ah, the wonderful world of ambiguous fonts on the web! The first word in that command should be LN (in lowercase letters). The rest looks okay.
     

Share This Page