New Mac Annoyance: Logging in Twice After Wakeup

Discussion in 'MacBook' started by nytivofan, Nov 17, 2008.

  1. nytivofan macrumors newbie

    Joined:
    Nov 4, 2008
    #1
    Everytime I wake up my new Macbook from sleep mode, I'm forced to enter in my password twice. There's a brief flash after the first login, then I get a second login screen after which everything starts up as normal. There was a thread on this a few months ago but no one seemed to have a solution. Since this is a new Mac for me, I'm not sure if this is normal or if anyone else is seeing the same problem. How can I fix this? It's pretty annoying.
     
  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    That typically happens to me when I put my mac to sleep, it wakes up (due to the disconnect of a bluetooth device or iPod, for example), and immediately falls back asleep before it's woken a second time.

    Might this apply to you as well?
     
  3. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #3
    It happened to me every now and then why i accidentally hit the mouse or the track pad and send the pointer to the hot corner to get the screen-saver started.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  5. joshuaaaron macrumors member

    Joined:
    Jun 10, 2008
    Location:
    Temecula, CA
    #5
    agree. when i unplug my mouse from my macbook while its sleeping i can see the screen turn on then shut back off. and when i open the screen and sign on i have to log in twice. just dont disconnect things. or disconnect bluetooth prior to sleep
     
  6. GfulDedFan macrumors 65816

    GfulDedFan

    Joined:
    Oct 17, 2007
    Location:
    Indiana
    #6
    You can cure the ill-effects of the double login thing by force quitting the program loginwindow. The ill effects for me when this happens are my F10 that I have set to put me in Spaces view doesn't work and I get no login screen when I return from screensaver. Also Sleep Mode becomes hard to enter.

    I goto Activity Monitor and highlight loginwindow and hit the Quit button then choose Force Quit. Make sure that you have exited all running programs first because this procedure logs you out and brings up a fresh login screen. -GDF
     
  7. Lexoticstylez02 macrumors 6502a

    Lexoticstylez02

    Joined:
    Oct 11, 2007
    Location:
    Orlando, Florida
  8. nytivofan thread starter macrumors newbie

    Joined:
    Nov 4, 2008
    #8
    I wanted to give an update on this problem-it was definitely related to the Bluetooth mouse I use (Microsoft BT Mouse 5000). If I shut off the mouse before closing the Macbook lid, I don't get the double login the next time I use the computer. I haven't 100% proven this, but I think by unchecking the "Allow Bluetooth devices to wake this computer" box in Bluetooth preferences, I also solve the double login problem.
     
  9. discoforce macrumors 6502a

    discoforce

    Joined:
    Jan 27, 2004
    Location:
    Vermont, USA
    #9
    Happens to me almost every time I open my macbook lid, and sometimes I have to close the lid again to even get the first login screen.

    I thought this was normal, it happened pretty consistently with the powerbook I had for 5 years.

    No bluetooth devices connected, though I do have an iPod touch charging.
     
  10. stackpointer macrumors newbie

    Joined:
    Nov 18, 2008
    #10
    That issue happens here sometimes as well. It is not big deal having to enter the password twice but it's anyway a bit annoying.
     
  11. RaceTripper macrumors 68030

    Joined:
    May 29, 2007
    #11
    I also have this problem. Sleep on Mac OS X sucks eggs, especially when you also use an external monitor with a MBP, where the problem is worse. System sleep and wake is one area where Apple just hasn't gotten it right yet and MS has (my Dell with XP Pro has no problems with sleep and wake, ever).
     
  12. island macrumors 6502

    island

    Joined:
    Feb 19, 2007
    Location:
    CT
    #12
    When I get back to my office tomorrow I will try unplugging everything first to see if it changes anything. Could be the bluetooth Apple KB causing it too.... hmmm....
     
  13. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #13
    Try disabling your screensaver. Sometimes the first one for the sleep and the second for the screensaver.
     
  14. stackpointer macrumors newbie

    Joined:
    Nov 18, 2008
  15. brianchevy macrumors newbie

    Joined:
    Feb 8, 2014
    #15
    I had this same problem and I have video taped it for people to confirm that it is the same problem.

    it was caused by using the Migration Assistant with Apple Mac and it mucked up the FileVault2 situation and a bunch of file permissions. I have since resolved this problem. Click the link below to view the video I made and view the resolution.

    https://www.youtube.com/watch?v=6gDi5hKxyrA&feature=c4-overview&list=UUJJtYCukqfoSKndDcJzgd6w

    This has been resolved. The steps to resolve it are as follows:
    1) Make a full and complete backup using Time Machine to the External USB drive
    2) Reboot the system and hit <Command>-R to go into recovery mode
    3) Enter Disk Utility, Format the INTERNAL hard drive with a new File System
    4) Let the system reboot, INSTALL A NEW OS from Internet Recovery (it will automatically do this if you just say “reinstall OS"
    5) Log in and make sure that your user is NOT in the system, just a simple ADMIN user, delete corporate user name
    6) Reboot the system and use <Control-R> again to boot to recovery mode
    7) Use the "Recovery from Time Machine backup" option and recover system user and software (this is pretty cool, you can grab all the apps from before too) - be sure to recover ONLY the user you need, not the admin user or any other users.
    8) Reboot the system cleanly and notice that it's a SINGLE log in required, no longer 2 and all your data is there. WOHOOO!!!!

    ----------
     

Share This Page