New Mac keyboard - 10.4 only???

Discussion in 'Mac Accessories' started by potlatch, Sep 6, 2007.

  1. potlatch
    Expand Collapse
    macrumors member

    Joined:
    Dec 5, 2006
    #1
    Is it true that this keyboard only works with OS X 10.4 and higher? I have a computer running 10.3, and need a replacement keyboard on account of some retard spilling tea all over it.
     
  2. BornAgainMac
    Expand Collapse
    macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
    #2
    It should work with 10.5 too. It probably will work with 10.3 but perhaps not use any of the special buttons.
     
  3. potlatch
    Expand Collapse
    thread starter macrumors member

    Joined:
    Dec 5, 2006
    #3
    That's a bit rubbish for people who buy it on account of needing it to eject the disk drive etc!

    Can anyone confirm this is true?
     
  4. CortexRock
    Expand Collapse
    macrumors 6502

    Joined:
    Dec 3, 2006
    Location:
    Canterbury, England
    #4
    It requires 10.4.10 to use the new keyboard functions - when I first got the wired keyboard, the 'old' buttons did what they were supposed to do.

    Can't see any reason why it wouldn't work as a keyboard on an older OS version, but I can't say for sure.
     
  5. BornAgainMac
    Expand Collapse
    macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
    #5
    For example, the Expose button won't mean anything to Panther. I think that is what they mean. I have no problem using Apple keyboards on Gateways or Dells running Windows.
     
  6. _bnkr612
    Expand Collapse
    macrumors 6502a

    _bnkr612

    Joined:
    Mar 8, 2004
    #6
    FYI, Expose was introduced in Panther.

    Cheers.

    Edit: Reread your comment, I get ya now.
     

Share This Page